Auckland Testing Summary 25 May 2013

Tom Parker tom at
Sat May 25 05:37:42 EDT 2013

Auckland Testing Summary 25 May 2013
Who: Alana, Barry, Charlotte, Fabiana, Hans, John, Oliver, Tabitha, Tom

Testing olpc au build on XO-1.75 and dextrose on XO-4

One Education OS 1.2 (build au891) on XO-1.75:

The laptop fails to start with a white screen after choosing the name, 
age and colour if you enter a very large age. See After restarting you get another 
opportunity to enter the name, age and colour and things proceed 
normally if you enter a smaller age.

Write 79
Moa and Mohua - Sometimes you can’t toggle underline or bold if you 
select text across two lines. The behaviour here seems quite complex and 
not consistent. On one occasion we selected two lines and toggling 
underline caused the second line to toggle but not the first.

Moa - Can insert picture, table, change colour and fonts.

Collaboration on write between “nz” and “nzbuild”. Both laptops 
contributions are being added in black (previous builds have had 
different colours for different contributors). When highlighting some 
text and resizing it changed the colour (we did not touch the colour 

Manage to hang write by clicking on the “export to hypertext button”. 
The export dialog did not appear, write still repainted the screen 
(covering and uncovering it caused the menu bars and documents to 
reappear), but clicking on buttons or writing in the document didn’t do 
anything. The log was very strange but unfortunately we didn’t get a 
copy of it at the time and the laptop appears to have deleted it. We 
were unable to reproduce this.

Memorize - Collaboration in Memorize between “nz” and “nzbuild” failed 
first time on local area network wifi, but restarting and carrying out 
further tests could not reproduce. Both laptops tried initiating, played 
several games each time, and tried creating own game.

Maze works on “nz”.

Browse works on “Moa”.

Implode works on “nz”.

Typing Turtle works.

Tried to do collaborative chat on adhoc networking. Laptops could see 
each other but the shared chat window doesn’t show up in either laptop’s 
neighbourhood view. Repeating this by closing the chat and opening it 
again causes things to work.

Jam2Jam hangs every time every time you click the Regae button. It also 
hangs if you open it, click the keyboard button at the bottom and then 
click the stop button. In both cases it stops repainting it’s screen and 
consumes no cpu. There is nothing interesting in the log. Raised

The built in book The blue sky has very small text, and zooming in the 
browser makes it smaller because the the controls get bigger leaving 
less room for the page. Also the home button inside the page doesn’t 
seem to do anything.

You can launch Record more than once. Any record started while another 
record has locked the camera just show a white screen in the preview. 
Perhaps record should refuse to start when it can’t get the camera. If 
you quit the first record and the quit the second record, the second 
record will hang. You can’t shut down the laptop after encountering 
this, it hangs on the goodbye screen.

Did some collaboration testing in Record with two XOs. Both XOs took 
photos and the photos appeared on each others XOs successfully.

Where should we raise Maori localisation issues?

In Maori, Moon-13 fails to start and Clock-9 doesn’t speak. The days of 
the week are also written in English in Clock. We reported this in 
October: and 
for moon at least, Gary identified the problem in one of the following 
messages on the mailing list. Raised

The confirmation dialog for removing an item from the journal is not 
translated properly, it has “Continue”.

The names of items in the journal in Maori are all squashed up, see 
for the same laptop in maori and english. Raised

The “Game Name” string in the Memorize is not localized to Maori.
The “Click for Grouped Game” string in the Memorize is not localized in 
The “Save Game”, “Load Game”, “New Game” string in Memorize is not 
localized in Maori

In turtle art the “load example” context popup (hover over the 3rd to 
last button in the top toolbar) in maori shows “Uta …uira” even though 
there is plenty of room for more characters.

Interestingly the first time you hover over activities in the activity 
ring, many of the activities, even those with short names like Ruler and 
Scratch, show a “shortened” name with … in the middle.

XO-system 1a for XO-4 (build 34) on XO-4:

You can’t cancel the About Me screen.

Created this report in Google Docs with browse, everything worked well.

How do you close a tab using the keyboard in Browse?

Like the older build we’re testing on the XO-1.75, you can start 
multiple records. The first record locks the camera and the subsequent 
records display a white screen. However unlike in the XO-1.75, quitting 
the first one and then the second one does not cause the second record 
to freeze.

We also spent quite a lot of time talking with Barry Vercoe about a 
deployment beginning at Manaia school, about the establishment of an 
OLPC NZ charitable trust, and how best we can support NZ deployments. 
Given the recent developments, we have asked Barry to join the olpc-nz 
mailing list to keep volunteers up to date, so volunteers can provide 
appropriate support.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: power-logs.tar.bz2
Type: application/x-bzip
Size: 24488 bytes
Desc: not available
URL: <>

More information about the Devel mailing list