Auckland Testing Summary 23 March 2013

Gary Martin garycmartin at
Sun Mar 24 00:56:19 EDT 2013

Hi Tom,

On 23 Mar 2013, at 08:43, Tom Parker <tom at> wrote:

> Auckland Testing Summary 23 March 2013
> Who: Fabiana, John, Hans, Oliver, Tabitha, Tom
> Testing 13.2.0 Build 1 on XO-1.75 and XO-4
> No sound in TamTam or Speak on 3 out 5 XO-1.75s. Speak hung when saying a sentence, scratch failed to start with an error in it’s log about missing sound driver. Record hangs when you take a photo on those laptops that have broken sound. We have discovered that this is related to firmware Q4D27, as the two laptops that worked were still on Q4D24. Updating them caused the sound to stop working.
> On Karearea, the UI did not respond to mouse clicks or keyboard input, but the neighbourhood/friends/activity list keys worked. After 3 reboots this started working and we discovered the wifi doesn’t work, eth0 exists but is not configured. This laptop is one of the ones on which sound does not work.
> I have the /var/log/messages from a few laptops including Karearea's bad wifi boot if anyone is interested.
> Measure seems fine
> Physics still has the top of screen problem on XO-1.75 but is working very well on XO-4.

How critical do you think this one is? I have a patch from John that fixes this, it's related to hardware driver frame buffer support issues, but at the cost of some memory & performance cycles. Basically it removes pygame default screen buffering feature and does the buffering manually – no more white flicker at the top of the XO-1.75 redraw cycle, but not for free.


> The context menu on the activity ring is annoying. It takes a long time to appear and disappear.
> WikipediaEN works, WikipediaES works
> Browse still hangs on Zimbra. The PDF viewer embedded in browse doesn’t have a jump to page option, and in touch mode, you can’t use the scroll bar because you can’t reach it with your finger. If you open a pdf file, save it to the journal, close browse and re-open then you can’t close the pdf tab, raised
> Collaboration doesn’t work in write, does in chat. Access point, no school server. Nothing interesting in the log.
> Battery life on XO-4 C2 seems significantly improved over previous builds. We would be interested in a confirmation or otherwise of this in the power log analysis.
> <powerlogs.tar.bz2>_______________________________________________
> Devel mailing list
> Devel at

More information about the Devel mailing list