Auckland Testing Summary 6 July 2013

Walter Bender walter.bender at
Sat Jul 6 16:57:27 EDT 2013

On Sat, Jul 6, 2013 at 4:49 PM, Barry Vercoe <barry at> wrote:
> Tom (and I've added Rangan to this thread because Manaia is our first XO-Duo
> deployment).
> Thanks for your comprehensive testing yesterday.  I trust we can resolve at
> least some to these before Tabitha and I reflash the 25 new Duos in Manaia
> on Tuesday.
> NB:  I've noticed another issue on the Touch interface -- when starting any
> activity via Touch, there's no choice of whether Resume or Start New.  We
> always get Resume.  The Start New option comes only via the keypad or
> external mouse pointer.  Is this the intended behaviour?

Have you tried a "long touch", i.e., holding your finger down on the
icon until the menu appears? Then you should be able to select New.

> -- barry
> On 6/07/2013 10:01 p.m., Tom Parker wrote:
> Auckland Testing Summary 6 July 2013
> Who: John, Tabitha, Tom
> Testing XO-system 1a For XO-4 (build 46)
> Sugar 0.98.7
> Firmware Q7B35
> Found that my previously described customization script was not working
> right -- the /etc/sysconfig/keyboard change is overwritten during first
> boot! Updated the customization script to also hack olpc-configure. Will
> look at options to do this better later.
> Found that this build does not include the Maori translations for sugar
> itself. Worked with CJL to get the language pack into the customization
> script. We’re not sure how we missed this as we have done a moderate amount
> of testing with Maori in previous builds, perhaps we saw the activities
> translated to Maori (activities are built differently) and just didn’t
> notice that sugar itself had no Maori.
> The language selector is awful. It’s slow to appear, the drop downs don’t
> work the first time you use them and they scroll very slowly compared to the
> number of entries but too fast to easily spot your desired language.
> Sometimes when changing the language, when you click the restart now,
> nothing happens. If you click restart later and then restart the whole
> laptop the changes seem to take affect.
> Some activities that we were expecting to be there, were not (maybe we are
> getting confused between builds prepared for different deployments). There
> is no GetBooks but there is Read (without any books!). There is also no
> Infoslice. There is no SocialCalc. There is no eToys.
> In Browse we went to and tried to use the touch
> screen to write in the search but that didn’t work, you had to use the
> touchpad button to activate the search box. You also couldn’t just touch the
> button that starts the search, you had to use the touchpad button (or enter
> key). You could however use the touchscreen to select the activity to go to
> the activity page and touch to select download. Activities did however
> download successfully, install and run (like the Music keyboard activity
> btw).
> There used to be a menu on the left side of the homepage in Browse but it
> has gone on all the XO-4 homepages. You used to use that menu to access
> maps, images and sound files, as well as any published Infoslice activity.
> Maze works.
> Paint works well with touchscreen.
> Physics works well with touchscreen.
> Implode works well with touchscreen.
> Portfolio works.
> Measure works well with touchscreen.
> Labyrinth works.
> Write works and the Maori Macrons (now, after some changes) work. The
> insertion of a table changes the font to times new roman which is not
> actually a listed font available in Write.
> We’re not sure if there is a camera in the XO-4 SKU 303 serial SHC318001EC
> we just got from Australia, there is something there but it is at best
> mis-aligned. This laptop did get banged against a wall on it’s handle while
> it was closed. The direction of the impact was mostly parallel with the
> plane of the shut laptop and wasn’t too severe. Could this move the camera
> in the body of the laptop and also break it? Firmware camera test fails,
> record behaves reasonably (it only offers to record sound). Barry reports
> the second XO from the pair in this shipment has a working camera. The XO-4
> we got from Boston does recognise it’s camera on and it can take high and
> low quality video well. Will take photographs and wait for advice before
> opening.
> Moon still fails to start when the XO language is Maori. Previously reported
> in
> Clock - loving the new grab hands feature, still doesn’t talk when XO is in
> Maori. Maori issue also reported in the same 3971 ticket.
> Labyrinth and Maze are both called Kōwhīwhiwhi - suggests an inappropriate
> translation of Labyrinth (guess it should be translated to a word more
> appropriate for brainstorm/mindmap activity).
> On some laptops terminal is called Terminal and on others it is called
> Kāpeka.
> WikipediaEN has not had an activity name translation either but this might
> be deliberate.
> Turtleblocks activity has a partial translation inside the activity due to
> new blocks being added. The name of the Turtleblocks activity has not been
> translated (but again that might be deliberate).
> _______________________________________________
> Devel mailing list
> Devel at

Walter Bender
Sugar Labs

More information about the Devel mailing list