[Sugar-devel] [TRANSIENT ISSUE] 3G-Modem not being recognised

Jerry Vonau jerry at laptop.org.au
Wed Nov 21 03:31:41 EST 2012

On 21 November 2012 18:40, James Cameron <quozl at laptop.org> wrote:

> On Wed, Nov 21, 2012 at 06:29:42PM +1100, Jerry Vonau wrote:
> > Yawn, yup boring unless a sponsor of your deployment is a 3G service
> > provider, then it becomes a major 'has to work out of the box' from
> > a business point of view.
> Perhaps this service provider can provide technical support?
Not really, the 15 second cycle is just not enough time for usb-modeswitch
to work it's magic and then have NetworkManager bring up the 3G interface.
We could tailor adding the specific USB IDs for that provider's devices but
the rest of the world still suffers.

> > If it's as simple as adding a single entry to powerd's usb-inhibits
> > file like how 'hid' is treated then why has this not been done?
> My guess is priorities are elsewhere in the stack at the moment, and
> we have very few deployments demanding this be fixed.
I understand that part, lots of work, too few people.

> > I don't think having an end-user with no experience with USB IDs add
> > an entry to the usb-inhibits file, or having to remember to turn off
> > a major feature is the correct long term solution IMHO.
> Certainly not.  I didn't think you or Ajay were end-users though.  My
> advice to end-users would be to wait for the problem to be fixed, or
> ask their deployment technical people to turn off the major feature
> permanently, or build a fix.
We did the last option, seemed the better compromise for all of our users.


> James Cameron
> http://quozl.linux.org.au/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.laptop.org/pipermail/devel/attachments/20121121/5aa6ee2b/attachment.html>

More information about the Devel mailing list