[Sugar-devel] Wanting to know a bit of (NetworkManager) workflow upon resume-from-suspend

Ajay Garg ajay at activitycentral.com
Sat May 12 04:38:18 EDT 2012

Thanks Martin.
Very neatly explained !!!! :)

I tried the "rmmod/modprobe" hack in "olpc-configure", and it worked
(obviously because, this time the "/etc.modprobe.d/libertas.conf" could be
fetched/read from persistent storage). Mesh-icons were no more visible in
the neighborhood-view (both during reboot, and resume-from-suspend).

But I too felt that this is more of a hack, and not a clean solution.

So, I ventured out exploring dracut.
I created a initramfs image on my home/work laptop, hosting Fedora-14, via
the command ::

                           "dracut test.img"

and then listed the contents of it

                           "lsinitrd test.img"

I saw that "/etc/modprobe.d/*" files were a part of "test.img".
So, I think that these files _are_ included as part of the initramfs image,
as per say.


Is this observation (that /etc/modprobe.d/* files are included, as per say)
in line with what is expected?
If yes, that is kind of a relief, since that would mean that only
"/etc/modprobe.d/libertas.conf" is not being included (in initramfs that

Thanks and Regards,

On Fri, May 11, 2012 at 3:33 AM, Martin Langhoff
<martin.langhoff at gmail.com>wrote:

> On Thu, May 10, 2012 at 1:23 PM, Ajay Garg <ajay at activitycentral.com>
> wrote:
> > If I boot with "/security/develop.sig" folder in my pendrive,
> > a)
> > mesh-icons are observed in neighborhood-view, both during reboot and
> > resume-from-suspend.
> Welcome to the initramfs stage of your journey! When the laptop needs
> activation, it loads a different initramfs that among other things
> loads the libertas module.
> You need to get your /etc/modprobe.d/ files into the initramfs. For
> your vanilla build, look into dracut-modules-olpc. If you're hoping to
> get this integrated into a build with an alternative initramfs (hint:
> Ceibal) that build will have a custom version of dracut-modules-olpc.
> That is the right way. When the laptop is in secure mode, olpc.fth is
> _ignored_, so no chance to set a kernel cmdline there.
> An easier alternative might be to check for those flags under /sys,
> and if they are there, rmmod/modprobe libertas  for example in
> olpc-configure (so during early boot).
> m
> --
>  martin.langhoff at gmail.com
>  martin at laptop.org -- Software Architect - OLPC
>  - ask interesting questions
>  - don't get distracted with shiny stuff  - working code first
>  - http://wiki.laptop.org/go/User:Martinlanghoff
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.laptop.org/pipermail/devel/attachments/20120512/49e660f5/attachment.html>

More information about the Devel mailing list