Nandblasting not working in one xo

James Cameron quozl at
Fri Jun 29 05:58:40 EDT 2012

G'day Roshan,

I understand NANDblaster is not starting on a specific XO-1.

This might happen if an antenna is damaged; even if you can use
internet from Sugar.  Open Firmware configures the wireless card
somewhat differently to Linux.

We have a new antenna test function in development.  This firmware
update contains it:

You need an open wireless access point to run the test, but there does
not need to be any IP network behind the access point.

The test is used thus:

   ok essid NETWORK
   ok test-antenna

Where NETWORK is the wireless access point name.

During the test the following data are displayed:

- beacon received signal strength indicator, in dB,

- beacon signal to noise ratio, in dB,

- receiver noise floor, in dBm,

- average values of the above three data,

- receive and transmit antenna allocation.

For your problem, the "avg rssi" value is the most indicative.  You
should find it will react by decreasing (larger negative numbers) as a
result of stowing the antenna and placing a hand over the whole
antenna area.  Usually one antenna will be in use, and you can
find which one it is by changing which side of the laptop you cover.

During the test there are keyboard keys with special meaning:

- key 1 to select antenna 1,

- key 2 to select antenna 2,

- key s to perform network scan,

- key a to deassociate and reassociate with access point.

By default on power up reset, both antennas are selected, and this is
called diversity mode, shown as "d".  (However, the "d" key does not
effectively restore this mode after keys "1" or "2".  A wireless card
reset is probably needed.)

The test can be used to indicate the performance of antenna,
transmission coax, termination, socket, antenna switch, and receiver.

But there are sources of unreliability in the test:

a.  the radio noise environment,

b.  the precise position of the antenna or laptop, such as in a null,

These sources of unreliability make comparisons difficult, but if you
see substantially different values greater than 20 dB between the two
antennas, I suggest one may be damaged.

The test also does not test transmit by the laptop, only receive.
Since NANDblaster should only receive, this is okay.

If you identify an antenna as damaged, schedule the laptop for a
detailed repair.  Look carefully at the coax cable leading from the
laptop to the axle of the antenna.

If both antennas are performing fine in this test, then it is time for
me to dig deeper.  I'll next be available to do that on Tuesday your

On Fri, Jun 29, 2012 at 02:19:34PM +0545, Roshan Karki wrote:
> Hi,
> Similar to this problem,
> 025769.html nandblasting is not working in one xo while it works flawlessly in
> 10 others.
> Nandbalsting simply doesn't start in that problematic xo. OFW test-all reports
> no error and I also can connect and use Internet from sugar. Though all of the
> xo in sets have same firmware I even tried updating the firmware to latest
> version to see if it would help.
> "open-wlan 6 multinand-traffic? . close-wlan" doesn't return ffffffff. I tried
> changing server, starting them in different channel. What could be the problem
> here?
> Thanks.

James Cameron

More information about the Devel mailing list