XO battery/performance [Devel Digest, Vol 76, Issue 21]

Yioryos Asprobounitis mavrothal at yahoo.com
Wed Jun 27 01:16:34 EDT 2012

--- On Sat, 6/16/12, Richard A. Smith <richard at laptop.org> wrote:
> Your battery jumped from 58% to Full while only receiving
> around 30mAh of charge.  So it has issues.
> For an older battery I would suspect charge balance symptom
> but your serial number starts with 008 which is beyond the
> lot of problem batteries and you have indicated you already
> ran bat-recover.
> So either your battery was not really at 58% or its suffered
> a lot of capacity loss.
> The next step would be to do a full
> discharge/recharge/discharge cycle while running
> olpc-pwr-log (stop powerd first) to measure the existing
> capacity.
> A quick summary of the procedure:
> - Boot laptop; stop powerd; run olpc-pwr-log; disconnect
> external power let laptop power off shut off.
> - Remove battery;connect external power; boot; stop powerd;
> run olpc-pwr-log; insert battery; let charge to full;
> - Ctrl-C to stop olpc-pwr-log; re-run olpc-pwr-log;
> disconnect external power; let laptop power off;
> You can try to figure out the log files from the code I
> previously pointed you at or you can send them to me.

Sorry for the "narrative" mail but the test was done over several days so these are my "notes"
I run the powerlog at the conditions suggested and indeed around 70% charge there is a sudden change in MAh during discharging and ~65% when charging while the battery can take just 2Ah instead of 3+.

After that test, I run bat-recover once more I noticed several strange things.
When the battery charged fully (negative charge 7.4+ volts) had taken 1.6Ah starting from reportedly 35% full. 
I removed it to stop bat-recoverer, started the XO and the battery was showing 32% full! Shutdown, removed and reinserted the battery, was now 87% full. Set it to charge and was 100% within 1 minute!
Run bat-set-low and then bat-recover again but the battery was indeed "full" (too just 2.5 mAh before it went to negative charge).
On next boot was showing 100% 
Then I run the XO-1 at full CPU use and with the monitor ON, and took 2:20 hours before it shut down (almost average).

Then I run bat-recover again starting from empty. It fully charged taking 2372 mAh but the charge led never turned green. On reboot the battery was showing 74% Full
Then run bat-set-low > bat-recover but no more charge went into the battery and the power led never turned green. 
On restart was showing  80% but not charging any more.
Removed battery and power, put them back in and now was sowing 99% full and the power led started orange and turned green before even the UI came up.

Then left it 14h in the XO and the next day the battery was showing 100% Full (from 99% at shutdown)!
On a next attempt from full (98%), was showing 92% after 12h. 
Run it a bit for the battery to go to 70%. Left it in the XO for another 12h. On restart the battery was 62% full. 12 more ours latter was 53% full

What I can decipher from all these is that 
a) the battery has decreased capacity (or for some reason stops charging after ~70% full)  
b) at times, the controller is not transmitting/sensing the battery state properly.
c) The battery indeed looses too much charge while in the XO and this may not be related to its decreased capacity.
You can hopefully see more things from these. 
I do not know if anything can be done but if not, the  XO-1.75 is pretty battery-friendly so 2Ah will hopefully do ;)
-------------- next part --------------
A non-text attachment was scrubbed...
Name: pwrlogs.zip
Type: application/zip
Size: 41529 bytes
Desc: not available
URL: <http://lists.laptop.org/pipermail/devel/attachments/20120626/e1d03c03/attachment.zip>

More information about the Devel mailing list