buildrpm et al on the XO-1.75

Yioryos Asprobounitis mavrothal at
Tue Jun 12 02:08:45 EDT 2012

--- On Mon, 6/11/12, Martin Langhoff <martin.langhoff at> wrote:

> From: Martin Langhoff <martin.langhoff at>
> Subject: Re: buildrpm et al on the XO-1.75
> To: "Yioryos Asprobounitis" <mavrothal at>
> Cc: "OLPC Devel" <devel at>
> Date: Monday, June 11, 2012, 12:50 PM
> On Sun, Jun 10, 2012 at 5:52 PM,
> Yioryos Asprobounitis
> <mavrothal at>
> wrote:
> > I was trying few things with the arm-3.0-wip kernel and
> was building fine in both x86_64 machines and the XO-1.75
> itself!
> Heh! :-)

What is actually impressive is that with `make zImage modules',  on the XO-1.75 the kernel is compiled _faster_ than it cross-compiles in my dual core 2.8GHz x86_64 machine (with -j 3)!

> > The other problem I had on the XO-1.75(os13) was that
> although the kernel was building fine, the rpm building
> failed with:
> > `error: create archive failed on file
> /home/olpc/kernel_sources/olpc-2.6/olpc/SOURCES/olpc-3.0.tar.bz2:
> cpio: Bad magic'
> > That's too cryptic for me I'm afraid. Any pointers?
> No idea, other than running out of disk space. When I did
> build
> kernels on XO-1.75s, I did it on a USB HDD.
> > Could it be becase the source was patched?
> As it is setup, buildrpm grabs the latest commit from git,
> so it'll
> ignore any uncommitted changes.
> So, this is important: buildrpm builds from the latest git
> commit, and
> it takes a very long time -- so long that it is only usable
> with an
> automated build bot.

Committing the changes still results in the same "bad magic" error.
The funny thing is than ~/rpmbuild/BUILDROOT/ has all the files (boot, modules and devel) and if you copy them in their paces in the filesystem work just fine to boot os13 (with all their initrd voodoo :-)

Is the kernel source tarball that apparently gives the "bad magic" somehow. I was wondering if this is due to busybox that was installed, (it is a dependency for initrd building), and somehow is used to gzip the source resulting in the bad magic. I have seen the same error extracting rpms in busybox systems so I was wondering... 
Anyway to tell which one buildrpm is using?

> > Regarding the kernel changes I tried, I noticed that
> both usb and sound fail to build as modules but they are OK
> in the kernel.
> You may be booting from a USB HDD or USB "stick"... I'd have
> it built in.
> Booting from the mic port is a little bit less likely ;-) --
> but our
> audio driver is being revamped, and for good reasons.

I'm not questioning the wisdom of having usb and sound build in, I'm just wondering why they have undefined module info/symbols(?), resulting to fail modpost. 
The sound snd-soc-olpc-xo-1-75.ko is "homemade" so maybe was never put in since was not needed, but ehci-hcd.ko is the upstream no?
Regarding "sound as a module", this is because some ditros may need to (re)load snd to configure alsa/pulse properly.

More information about the Devel mailing list