Must just be my week for strange behaviour

Kevin Gordon kgordon420 at
Wed Feb 15 13:39:53 EST 2012

On Wed, Feb 15, 2012 at 1:34 PM, Paul Fox <pgf at> wrote:

> kevin wrote:
>  > I'm fixing up about 5 XO-1s I bought from eBay, all with what appear to
> be
>  > RTC issues.
>  >
>  > 4 all worked nicely, page fault error from the serial adapter console,
>  > entered the select/decimal/set-time, they rebooted and re-flashed very
> well.
>  >
>  > Alas, number 5, when I crank up the power, all that appears on the
> serial
>  > console is a '+' sign, no pretty Forth message, no Page Fault error,
> just
>  > that lonely arithmetic symbol.
>  >
>  > Went back to a couple of the others and verified that serial adapter and
>  > console still worked
>  >
>  > Is there a possiblity that this one beast might have a different baud
> rate
>  > or parity?  I didn't really want to try the o, let's say, 32768
> different
> no, it's not a baud rate or parity issue.  if you look closely at the
> serial output from one of your working machines, you'll see that the
> very first character produced by OFW is '+'.  <cr><nl> or <nl><cr> is
> next, then the Forthmacs strings.  i believe mitch uses every one of
> those characters as a progress indication.  dying as early as your
> machine does is probably not a good sign.


And I left my JTAG in my other pants.


I'll put it into the 'Investigate Later' bin, as it looks like it might
take a fair amount of time/effort with an appreciable chance of ultimate
failure.  Back to the 1.75 I go .....

Thanks everyone for the quick replies.


> paul
> =---------------------
>  paul fox, pgf at
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Devel mailing list