Testing Summary Auckland 25 August 2012

Tom Parker tom at carrott.org
Sat Aug 25 18:24:03 EDT 2012

Testing Summary Auckland 25 August 2012
Who: Fabiana, John, Tabitha, Tom
Testing 12.1.0 Build 20 on XO-1, XO-1.5 and XO-1.75.

Simba XO-1
Measure: starts up ok - single channel recording. Gain and time control 
seem ok. Waveform looks reasonable - FFT ok. Pause ok. Query: Are these 
scaling controls on a log scale? Sample: I don’t see the frozen screen 
of what is being captured every time interval -- I thought I was able to 
see that before?
Paint: seems ok
Shutdown: cannot shut down through right click (although option is 
there) nor can I restart - need to push power button but didnt show me 
the shutdown screen so was confused.

Moa XO-1.75
Measure: starts up ok - two channel recording -  Gain and time control 
ok,  Query: Are these scaling controls on a log scale? The refresh  is 
set so that I seem to always have two waveforms from a single channel at 
any time - so you can’t really look at a single waveform at any time - 
there are advantages to this, but it can be kind of confusing - I don’t 
get the same problem with Simba. FFT ok, except here too I get 2 
consecutive waveforms displayed. Sample: I don’t see the frozen screen 
of what is being captured every time interval -- I thought I was able to 
see that before? Records of sampling seem ok when opened from the 
journal. The log of the samples seem odd - they don’t seem to reflect 
what I did. I started recording at 1 sec interval and changed to 30 sec 
after about 5 sec but hard to understand what the log is showing me when 
I open it as a text file. The metadata seems fine - but am a bit 
confused at the data structure. (same on simba)
Physics: I still get the funny thing at the top of the screen where it 
displays intermittently the image - I can trigger this behaviour by 
building a tall rectangle that spans the height of the canvas.
Memorise: all three grids work
Paint: seems to work ok

Ivy XO-1.5
Record works, initially video quality was poor but restart of the 
activity fixed it
Write works
Getbooks and Read work. Getbooks icon in home view circle does not 
colour after use and there is no record of use in the Journal, but the 
book downloaded does show in the Journal. Read icon does colour when 
displayed in the home view circle (after you read a book).
Measure - looks good on first opening of activity, unlike Rosella
Wikipedia EN - works
Tamtam mini - works
Browse - works
Maze - works on own

Rosella - XO-1.5
Maze - can play on own, could invite Ivy on local wifi but Ivy couldn’t 
join. The icon appeared in frame area but clicking it never resulted in 
Maze opening, just get X in the middle. Tried joining from neighbourhood 
and got Maze to open but it opened new Maze not the shared one. Then Ivy 
couldn’t see Rosella in neighbourhood but Rosella can see Ivy. Rotate no 
good, doesn’t resize to fit so part of maze is not visible in 90 and 270 
view (but when would you use this view?).
Implode - level 1 works, rotate is okay and can complete using all angles
Ruler - works, rotate doesn’t resize thankfully so your ruler is still 
accurate! It does go off screen in 90 and 270 view
Speak - pitch/rate, eyes/mouth work, robot works, didn’t test 
collaboration. Rotate works on all angles, 90 and 270 view the buttons 
change to drop down menu nicely.
Finance - works, would really like a repeat function for recurring 
events like regular income so you don’t have to do so much typing. 
Rotate works.
Moon - works, rotate works (resizes to fit)
Tamtam mini - works, rotate not so good though as doesn’t resize to fit 
90 and 270 view (though you do get scroll bar).
Clock - works, rotate is fine, would be good to change DDMMYY order to 
match local expectations
Memorize - all 3 preloaded games and sizes work, create and play own 
game works, rotate works
Stopwatch - works, rotate works
Chart - works, rotate resizes to fit
Measure - on one startup it went crazy! 
Suspend/resume by closing lid and the Measure display is fixed. Is this 
http://bugs.sugarlabs.org/ticket/2509? we’ve seen it a few times on 
production laptops, so perhaps we were too quick to assume it was 
prototype hardware related?
Browse - works

We received two XO-1 laptops which refused to turn on, following the 
http://wiki.laptop.org/go/Fix_Clock instructions to set a valid time via 
the serial port fixed both of them. The clock batteries appeared to be 
working, in place and not leaking. They both had very old software which 
had the nice feature of showing which activities are running on the home 
screen. They now have 12.1.0 build 20 and are on their way back to their 

On XO-1 (and presumably the others, I didn’t try), using yum to install 
ntpdate causes a strange prompt to import a key. It seems that the key 
is already present on the laptop but yum doesn’t trust it, but it 
certainly doesn’t present enough information to make a reasonable trust 
decision. Also, we see an error about the rpmdb checksum, but ntpdate 
seems to work anyway.

Downloading Packages:
   |  76 kB     00:00
warning: rpmts_HdrFromFdno: Header V3 RSA/SHA256 Signature, key ID 
1aca3465: NOKEY
Public key for ntpdate-4.2.6p5-2.fc17.i686.rpm is not installed
Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-i386
Importing GPG key 0x1ACA3465:
  Userid     : "Fedora (17) <fedora at fedoraproject.org>"
  Fingerprint: cac4 3fb7 74a4 a673 d81c 5de7 50e9 4c99 1aca 3465
  Package    : fedora-release-17-1.noarch (@koji.dist-f17-i686/$releasever)
  From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-i386
Is this ok [y/N]: y
Running Transaction Check
Running Transaction Test
Transaction Test Succeeded
Running Transaction
   Installing : ntpdate-4.2.6p5-2.fc17.i686 

Rpmdb checksum is invalid: dCDPT(pkg checksums): ntpdate.i686 
0:4.2.6p5-2.fc17 - u

More information about the Devel mailing list