EC corruption by q2f04rc firmware

Hal Murray hmurray at
Mon Oct 31 15:34:32 EDT 2011

mikus at said:
> To date I have one 2007-vintage XO-1 with q2f04rd (and os882).  It  worked
> normally (and never lost charge while plugged in to AC) until I  closed the
> lid (thereby putting it into suspend).  Upon opening the lid  and pressing
> power, the power light changed to red, and the native XO  green keyboard no
> longer worked. 

I can reproduce this, or something very similar.  I'm using q2f04rc and 883 
on a XO-1 c2

For me, the key is to make it happen is removing AC power.  Closing and 
opening the lid works normally if the AC is plugged in.

Without AC, I've seen the battery LED go red at least twice, but I can't make 
it happen now.

Ahh... found it.  I only get the red LED if the battery is fully charged.

What do you call the LED next to the battery LED that indicates that the 
system is running?  That's tangled up in this confusion too.  I've seen my 
system running when that LED is off and seen it turn on when I poke the 
power-off button and back off when I try to start the system.  I'll call it 
the CPU LED.

Starting with a full battery and no AC, the pattern is:
  battery LED is off, CPU LED is on
  close lid
  short delay
  CPU LED goes out
  few second delay
  battery LED goes orange
  few second delay
  battery LED goes red
  open lid (I've got it setup to auto start)
  system goes active, CPU LED stays off, battery LED stays red, keyboard 
doesn't work


Where is the nice big picture of the XO with labels for everything?  (I 
thought I had it bookmarked.)  How do I find it at times like this?

These are my opinions, not necessarily my employer's.  I hate spam.

More information about the Devel mailing list