11.3.0 release candidate 4 (build 883) released

Anish Mangal anish at sugarlabs.org
Wed Nov 2 00:17:15 EDT 2011

Hash: SHA1


For 'digital zoom', Telescope uses the videobox gst element. Maybe
that's where the problem is.

Unfortunately, I don't have much time to debug it myself on a 1.75
right now.

Also, from what I gather, the digital zoom does work on a xo 1.5, so
the problem does seem xo1.75 specific at the moment.

Hope this helps.

On 11/01/2011 05:19 PM, Niels de Vos wrote:
> On Tue, Nov 1, 2011 at 11:24 AM, Niels de Vos
> <devos at fedoraproject.org> wrote:
>> Hi Gary,
>> On Mon, Oct 31, 2011 at 6:41 PM, Gary Martin
>> <garycmartin at googlemail.com> wrote: ...
>>> I've just been testing Telescope-12 on the XO-1.75 running the
>>> new 883 build, first the good news, the camera is showing up
>>> correctly in Record and Telescope, fab! :) Now the not so hot: 
>>> - While in Telescope-12, clicking the digital zoom toolbar
>>> button completely locked up the XO-1.75 (re-testing with an
>>> XO-1 the digital zoom works ok). - After some waiting and many
>>> attempted keyboard shortcuts, I decided to power down. Clicking
>>> the power hardware button did not trigger the usual shut down
>>> screen during this particular lockup case; clicking the power
>>> button twice (assuming it might just be the gfx that had
>>> locked-up) had no effect; finally I held down the power button
>>> for some seconds until the power led flashes and then the hard
>>> powers off. - On reboot the Journal now shows 3 corrupt entries
>>> (see attached screen shot) with no name and unknown metadata.
>>> None of the three entries allow invoking the details view or
>>> raise their palette so can not be erased via the Sugar Journal
>>> UI. The three corrupt entries will be an entry for Browse where
>>> I visited ASLO to download telescope and then quit Browse; the
>>> downloaded Telescope-12 bundle; and the instance entry for the
>>> Telescope that was running when the XO locked up. Given the
>>> nature of the hard power off I understand why some data would
>>> not have been synched to disk, but just wanted to raise this
>>> case here. I guess the actionable items might be: 1) fixing
>>> Telescope-12's digital zoom not to lock up an XO-1.75 (I don't
>>> have an XO-1.5 to test but I re-checked on an XO-1 which still
>>> worked fine). 2) Seeing why the XO-1.75 hard crashed, I'm
>>> assuming something camera driver related may have borked badly
>>> (I do have a serial cable here for un-bricking an XO-1.75 but
>>> don't know my way around that side of things very well).
>> I tried to reproduce with Telescope, and I get an oops/hang as
>> well. The same oops is already filed as
>> https://dev.laptop.org/ticket/11128.
>> Using a serial console for logging may show if it is a
>> panic/crash or a hang (like a very busy loop). If you unbricked
>> your XO-1.75 with an other Linux system, you should be able to
>> use minicom to capture a log in a similar way.
>> After starting minicom, press CTRL+a,z (press CTRL+a together,
>> release them, press 'z') to get in the minicom help/menu.
>> Pressing 'l' will ask you for a filename, I'd use samething like 
>> xo-1.75-camera-issue.log. After pressing return, everything will
>> be saved. Now turn on the XO and reproduce the issue.
>> When you encounter the panic/hang again, press CTRL+l in minicom
>> to close the logfile and exit minicom.
>> I'll try this as well, but am still running build 882 which may
>> be differnt than build 883 in this respect.
> The result I have with build 882 and Telescope: - working nicely -
> click 'diigital zoom' - Telescope gets unresponsive (no picture
> anymore) - oops over the serial console - mouse and keyboard are
> still functioning - Telescope can be (forcefully) stopped -
> Telescope fails to sart (requires reboot) - no additional oopses
> recorded
> The oops is available in #11128.
> HTH Niels

- -- 
Anish Mangal
Sugar Labs
Version: GnuPG v1.4.11 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/


More information about the Devel mailing list