olpc-update works on XO-1!

S Page skierpage at gmail.com
Mon Jun 27 06:13:40 EDT 2011

On Fri, Jun 17, 2011 at 15:05, Yioryos Asprobounitis
<mavrothal at yahoo.com> wrote:

> Well, the good news is that updating from os860 tp os23 is possible!

But doesn't 11.2.0 change the partitioning (but no longer, as I
understand it, changes the file system from jffs2 to ubifs)?  Surely
olpc-update doesn't change that.

> The bad news is that it needs ~470MB of free space to work and os860 pristine leaves only ~380MB free.

I think those space requirements should be in Release notes/11.2.0.  I
think there's a page somewhere on the wiki about freeing up storage
space, but I couldn't find it.

I tried `sudo olpc-update candidate-870` with 159MB free.  First
attempt restarted sugar after less than a minute (probably OOM, I may
have had other activities than Terminal running). My second attempt
with -v -v quickly freed up 340MB or so after "Deleting old
pristine/run/contents for  version a04blah blah", then ground away
rsyncing, before failing with
 rsync error: errors with program diagnostics (code 13)...
 Attempt olpc_update_irsync_pristine failed... returned non-zero exit status 13
Then it tried irsync_dirty update that silently failed (maybe it
couldn't update my log file), at which point I had 11MB free.

Is there a way to tell which Record entries in the journal take up the
most space?

=S Page

More information about the Devel mailing list