Record activity performance

Sridhar Dhanapalan sridhar at
Thu Jan 6 22:51:59 EST 2011

On 24 December 2010 10:36, Sridhar Dhanapalan <sridhar at> wrote:
> On 23 December 2010 17:10, James Cameron <quozl at> wrote:
>> On Thu, Dec 23, 2010 at 04:53:26PM +1100, Sridhar Dhanapalan wrote:
>>> Firstly, I tried Record after having used the XO with various
>>> activities (Musicpainter, Image Thumbnail, etc.) and closed them
>>> (leaving nothing else running). Recording in Low for 2 min appeared to
>>> work, but playback gave no sound, and it paused after about 10
>>> seconds.
>> That's interesting.  I've not heard about that.  What version of those
>> activities?  Where do you get Musicpainter from?  I can't see it at
>>  Nor can I see anything called Thumbnail.
>> If these activities change the mixer controls at all then this may lead
>> to the "no sound" symptom you describe.
> Musicpainter and Image Thumbnail are new activities created by us,
> which we haven't yet fully released (I haven't submitted them to ASLO
> yet). I'm now suspecting that the Musicpainter is the culprit, so
> that's our problem to investigate.
> The project pages for those activities are:

I've seen this happen with no other activities having been run, so
it's not related to Musicpainter or Image Thumbnail.

I tried with on an XO with 10.1.2:

  1. boot the XO
  2. load Record
  3. record some video
  4. play back the video

I expected the video to be played back with full audio and video. What
I saw is playback for a few seconds, then it halts.

I'm having trouble reproducing. It seems to happen only on odd
occasions. I'll keep investigating.


More information about the Devel mailing list