Minor 11.2.0 update problems

Jack Zielke laptop at linuxcoffee.com
Fri Aug 5 23:56:30 EDT 2011

On Fri, 5 Aug 2011, Mikus Grinbergs wrote:

> In my systems, I've had the Activities on the SD card for years.  I ran into
> your problem I think in 2009.  My solution:

Thank you Mikus.  I may adapt that to my XO.  I had only moved the largest 
3 activities so it could be that they were not showing up and I had not 
noticed.  I moved all of the activities (made /home/olpc/Activities a 
symlink) and nothing shows up on boot.  Hard to miss that =]

On Sat, 6 Aug 2011, James Cameron wrote:

> On Fri, Aug 05, 2011 at 09:53:16PM -0400, Jack Zielke wrote:
>> I updated my XO-1 to 11.2.0 today.  I ran into a few minor issues
>> that I thought I would mention.
>> /etc/ssh/ssh_host_*key* were not saved during the update.  I did not
>> have a copy of them anywhere so I had to make new keys.  That is a
>> bit of an annoyance since I have to remove the old key from each
>> machine that I have sshed into the laptop from.
> Interesting.  What method did you use to update?

sudo olpc-update --usb

>> Any warning on sshd changes would have been nice.
> Good point.  It wasn't in the release notes.  I've added a tiny section.
>> I did check http://wiki.laptop.org/go/Ssh_into_the_XO to make sure
>> this was not already documented there.
> That page had not been maintained since 2008.  I've adjusted it.  Please
> review the page and adjust further based on what you find.  In
> particular, the section for Microsoft Windows systems may be out of
> date.

Thank you.  If I am the only person that lost their ssh host keys then 
what is there looks great.

>> I suspect that the order of things has changed.  It appears that
>> Sugar is starting up before /media/* is being mounted.  I had moved
>> the larger activities to an SD card and now they no longer show up
>> when the laptop boots.  After the GUI is completely drawn I can
>> ctrl-alt-backspace to kill X.  When it comes back up all of the
>> activities are available.  I think this means that moving /home/olpc
>> to the SD card is out of the question.
> Interesting.  That sounds like Sugar taking longer than before to start
> up, but you're right, it could be an order of things change.  You might
> work around it by mounting the SD card in /etc/rc.local.
>> These were not huge issues for me but they were different from every
>> other upgrade I have done in the past on my XO.
> Thanks for your feedback!

And I thank you both for yours!


More information about the Devel mailing list