using libertas_tf with F11 on XO-1

Assim Deodia assim.deodia at
Thu Jun 10 14:20:53 EDT 2010

Hi Martin,

On Thu, Jun 10, 2010 at 21:45, Martin Langhoff <martin.langhoff at>wrote:

> On Tue, Jun 8, 2010 at 12:18 PM, Assim Deodia <assim.deodia at>
> wrote:
> > I am trying to load libertas_tf_usb module on XO-1 to use it as an AP.
> > but when I modprobe libertas_tf_usb (after unloading libertas and usb8xxx
> Hi Assim!
> I don't think many people have been playing with it recently -- though
> it is important and we'd love to see it working (and a howto, or
> patches, if you come up with any).
> I can suggest some leads to follow:
> AFAIK, the libertas_tf we carry is the same as upstream, so these
> instructions are relevant
I have already followed these instructions as it is. They are same as on But for some reason
they does not seems to be working. atleast not at my end.

You are talking about building your own kernel -- was libertas_tf not
> compiled for the kernel on F11/XO-1?

libertas_tf doesn't come compile in pre-build kernels. I have rebuilt the
kernel rpms with libertas_tf and libertas_tf_usb enabled. if anyone
interested in testing at their own end can get the rpms from me.

> > I also tried blacklisting libertas and usb8xxx but still they are loading
> at
> > the boot time.
> That's weird, but may be happening in the initramfs.
> If the above hints don't help, might be time to open a conversation at
> linux-wireles
I will try some more hacks at my end else will mail the above list. Thanks
for the pointers.

> cheers,
> m
> --
>  martin.langhoff at
>  martin at -- School Server Architect
>  - ask interesting questions
>  - don't get distracted with shiny stuff  - working code first
>  -

Assim Deodia
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Devel mailing list