Some testing notes for OS10 for the XO-1

Paul Fox pgf at
Sun Jan 3 09:31:23 EST 2010

 > On Sun, Jan 3, 2010 at 02:40, James Smith <metal.lunchbox at> wrote:
 > > All seems to work pretty well. except powermanagement. I'm running os10 
 > updated today with kernel, modules, firmware from 12/28 . the default setup 
 > with powerd gives the previously described problem, losing keyboard and mouse 
 > upon wakeup. ohmd gives similar results.

if i have a suitable XO-1 here at home, i'm going to fix this
keyboard/touchpad loss issue today.  it'll give me something to do
before having to shovel out of our fresh snowstorm.

 > pm-suspend ends immediately prior to 
 > actually suspending to ram after blanking screen and disconnecting wireless. 
 > The keyboard but not the mouse is almost always lost when using pm-suspend. 
 > Suspend with hal directly from the command line gives the same results:
 > > dbus-send --system --print-reply --dest=org.freedesktop.Hal \
 > >  /org/freedesktop/Hal/devices/computer \
 > >  org.freedesktop.Hal.Device.SystemPowerManagement.Suspend \
 > >  int32:0
 > > Why does this command not work?

we've never used, nor supported, pm-suspend on either XO-1 or
XO-1.5.  it's likely that in its default configuration it won't
do the right things vis-a-vis our display.  (i.e., sleep, by
itself, won't turn off our display.)

 > More importantly, why does powerd work 
 > (except for the wakeup problems)? I'm guessing it doesn't use hal or dbus at 

correct.  ohmd doesn't use hal either (i don't think), but it
does make extensive use of (mostly private) dbus messages for
configuration and control.

 > all.  I'd like to help work on this problem but I don't know
 > much about power-management and I don't really know how to
 > test it further.  Is there a place where os10 development
 > issues are tracked or is it just this mailing list?

this mailing list is the place, as well as trac for specific bugs.

 paul fox, pgf at

More information about the Devel mailing list