[Sugar-devel] Problem importing hulahop.webview() in sugar emulator

Vijit Singh vijit at seeta.in
Mon Feb 15 13:56:49 EST 2010

Hello Tomeu and Aleskey,

Thank you for your replies. I will test your suggestions in a day or two and
will let you know about the results since I have been out of town and hence
unable to access net since the last 2 days.

On Sun, Feb 14, 2010 at 1:14 AM, Tomeu Vizoso <tomeu at tomeuvizoso.net> wrote:

> On Fri, Feb 12, 2010 at 23:36, vijit singh <vijitthetopcoder at gmail.com>
> wrote:
> > Hello everyone,
> > SocialCalc is based upon the use of hulahop.webview widget. While trying
> to
> > run socialcalc on sugar emulator running on Fedora and Ubuntu, error
> saying
> > "No module hulahop" was occurring. So, we tried installing hulahop on
> these
> > linux distributions.
> > 1. Firstly we tried with ubuntu-8.10, here are the exact steps taken-
> >
> >  xulrunner was pre-installed. And then I installed python-support.deb and
> > libxul0d.deb which are pre-requistie packages for python-xpcom package
> > (other pre-requistie packages were already installed). Then i installed
> > python-xpcom. And then I installed python-hulahop and hulahop.
> >
> > Downlaod links for these packages are as follows:-
> >
> > http://packages.ubuntu.com/en/intrepid/python/python-xpcom
> > http://packages.ubuntu.com/en/intrepid/hulahop
> > http://packages.ubuntu.com/en/intrepid/python-hulahop
> > Now, though hulahop was getting imported but while using hulahop.webview,
> an
> > error saying "hulahop has no attribute webview" occured. However, when we
> > checked the hulahop folder, there was a file named webview.py, so this
> > problem might be because of some kind of wrongly set library paths.
> > 2. Then we tried it with ubuntu-9.10, with similar steps but got the same
> > result.
> > 3. Then we tried it with fedora-11-
> > Installed hulahop and then xpcom from the following
> > link-
> http://www.rpmfind.net/linux/RPM/mandriva/2009.1/i586/media/main/release/python-xpcom-
> This is a Mandriva package. I recommend using the tools available in
> each distro for installing software. In Fedora it would be: "yum
> install hulahop"

We tried yum install hulahop but it said no package named hulahop, our first
approach on fedora was to use yum and on ubuntu was to use apt get, but both
gave the same results.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.laptop.org/pipermail/devel/attachments/20100216/a8e3ddca/attachment.html>

More information about the Devel mailing list