[Sugar-devel] Problem importing hulahop.webview() in sugar emulator

Tomeu Vizoso tomeu at tomeuvizoso.net
Sat Feb 13 14:44:52 EST 2010

On Fri, Feb 12, 2010 at 23:36, vijit singh <vijitthetopcoder at gmail.com> wrote:
> Hello everyone,
> SocialCalc is based upon the use of hulahop.webview widget. While trying to
> run socialcalc on sugar emulator running on Fedora and Ubuntu, error saying
> "No module hulahop" was occurring. So, we tried installing hulahop on these
> linux distributions.
> 1. Firstly we tried with ubuntu-8.10, here are the exact steps taken-
>  xulrunner was pre-installed. And then I installed python-support.deb and
> libxul0d.deb which are pre-requistie packages for python-xpcom package
> (other pre-requistie packages were already installed). Then i installed
> python-xpcom. And then I installed python-hulahop and hulahop.
> Downlaod links for these packages are as follows:-
> http://packages.ubuntu.com/en/intrepid/python/python-xpcom
> http://packages.ubuntu.com/en/intrepid/hulahop
> http://packages.ubuntu.com/en/intrepid/python-hulahop
> Now, though hulahop was getting imported but while using hulahop.webview, an
> error saying "hulahop has no attribute webview" occured. However, when we
> checked the hulahop folder, there was a file named webview.py, so this
> problem might be because of some kind of wrongly set library paths.
> 2. Then we tried it with ubuntu-9.10, with similar steps but got the same
> result.
> 3. Then we tried it with fedora-11-
> Installed hulahop and then xpcom from the following
> link- http://www.rpmfind.net/linux/RPM/mandriva/2009.1/i586/media/main/release/python-xpcom-

This is a Mandriva package. I recommend using the tools available in
each distro for installing software. In Fedora it would be: "yum
install hulahop"

> Now, when we tried to use hulahop.webview, the following error
> occured- http://pastebin.be/23452. though hulahop was getting imported
> properly in this case as well.
> Could someone please guide us about what are right steps in case we are
> wrong somewhere. Also has anyone been able to use
> hulahop.webview  successfully on linux distros before?

Sugar's Browse is known to run in all those distros (and many more),
though in the Ubuntu case I think you need to use PPAs as explained




> Regards,
> _______________________________________________
> Sugar-devel mailing list
> Sugar-devel at lists.sugarlabs.org
> http://lists.sugarlabs.org/listinfo/sugar-devel

More information about the Devel mailing list