Problem importing hulahop.webview() in sugar emulator

vijit singh vijitthetopcoder at
Fri Feb 12 18:36:38 EST 2010

Hello everyone,

SocialCalc is based upon the use of hulahop.webview widget. While trying to
run socialcalc on sugar emulator running on Fedora and Ubuntu, error saying
"No module hulahop" was occurring. So, we tried installing hulahop on these
linux distributions.

*1. Firstly we tried with ubuntu-8.10, here are the exact steps taken- *

* **xulrunner was pre-installed. And then I installed python-support.deb and
libxul0d.deb which are pre-requistie packages for python-xpcom package
(other pre-requistie packages were already installed). Then i installed
python-xpcom. And then I installed python-hulahop and hulahop. *

*Downlaod links for these packages are as follows:-*
* <>***<>

Now, though hulahop was getting imported but while using hulahop.webview, an
error saying "hulahop has no attribute webview" occured. However, when we
checked the hulahop folder, there was a file named, so this
problem might be because of some kind of wrongly set library paths.

*2. Then we tried it with ubuntu-9.10, with similar steps but got the same
*3. Then we tried it with fedora-11-*
*Installed hulahop and then xpcom from the following link- **

Now, when we tried to use hulahop.webview, the following error occured- though hulahop was getting imported properly in
this case as well.

Could someone please guide us about what are right steps in case we are
wrong somewhere. Also has anyone been able to use
hulahop.webview  successfully on linux distros before?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Devel mailing list