USB Ethernet test

Kevin Gordon kgordon420 at
Sun Dec 26 16:04:01 EST 2010

Sorry for the delay.  Here's my latest update. Did this using only two XO
1.0's, running Build 360.  This could all be behaviour by design, and I'm
not reporting any bugs here, just listing what I've done in testing.

Each command entered on one XO, then the other in turn.

Fresh copy-nand installs on both
booted to sugar desktop
disable radio from settings
veriified only one little xo symbol in the middle of each screen, none
others visible
plug in the USB ethernet adapter
lsusb shows adapter in the list
dmesg shows some messages and registers ASIX to eth0
ifconfig shows only loopback, not eth0
waited for eternity less 1, still no eth0 on ifconfig
restarted with etherenet adapters and cables still installed, still no eth0
on ifconfig
also, just for info no usb symbol int eh frame, just battery and sound.

switched to gnome desktop

network icon in top right showed network disabled
lsusb shows usb ethernet adapter
ifconfig shows only loopback
right-clicked icon,  selected checkbox: enable network
ifconfig now shows eth0 withan auto-assigned IPv6 address
ping6 bewteen machines works fine

switched to sugar desktop
network neighbourhood stil just shows itself
fconfig shows eth0 with IPv6 address auto-asigned
ping6 between machine works fine

entered the following commands:

route add default dev eth0 metric 99
route add -net netmask dev eth0 metric 99
/usr/sbin/avahi-autoipd --daemonize --syslog --wait eth0
route add -net netmask dev eth0

network neigbourhood now shows both XO's on each XO
ping to 169.254.x.x between machines is working

started a chat on XO A sharing to neighbourhood
went to network neighbourhood map did aright-click on the chat icon and
all good for collaboration in chat.
still no USB ehernet adapter icon in the frame.

Notes:  after subsequent reboots and then switching desktops back to gnome,
the first boot to gnome side showed that the wireless enabled checkbox was
now checked on, and eth0 had become the wireless adapter.  The USB adapter
became known as 'eth1_rename', on both the Gnome and Sugar desktops  Ping6
stlll worked fine between the two machines when specifying that new
interface name.  It came up consistently after the next reboots as
eth1_rename on the Gnome and sugar side.  The avahi-autoipd command,
although showing no  errors, no longer created the secondary autoipd adapter
in ifconfig, and network neighbourhood map and collaboration did not work.
once the interface had the "_rename" suffix.  Perhaps just the catenation
string got too long, dunno.

Another interestng difference is that on the Sugar side, with radio
disabled, lsusb just shows the two bus entries, and the USB ethernet
adapter, and ifconfig just shows the USB ethernet and the loopback;  but, on
the gnome side, even with wireless enabled checkbox off, there is an entry
of 1286:2001 Marvell Semi-conductor Inc.  in lsusb, and there is a msh0
interface still coming up, as I said, even with the gnome network manager
wireless checkbox off.


I could never get the eth0 interface to come up after a fresh install after
disabling radio on the sugar side, without going to the gnome desktop and
enabling networking. I might try by plugging in the adapter with radio on so
that it might get an eth1 interface, that wouldnt ever get renamed, but I
haven't done that. Let me know if you want me to.
I could never, ever see a USB ethernet icon in the frame.
I could only get collaboration working by entering the 3 route commands and
1 avahi-autoipd command in the sugar terminal, even though the icons show up
in thee network map with just the avahi-autoipd command, ping works, but
collaboration does not seem to work without the route commands
Neither Gnome nor sugar desktops ever assign an IPv4 IP address (169.54.x.x)
automatically in 852/359/360 like they did in 802.  Neither my Ubuntu 10.04
nor my Fedora 11 box seem to auto-create 169.254.x.x addresses either.  All
my Windows and Apple boxes do.

Conclusion for me:  If i really needed a hard-wired ethernet connection
where I didn't have a DHCP server, I'd use a static 10.x.x.x IP,  It takes
less of my poor typing skills, and seems more 'auto' than what is termed the
'auto' workaound.  I also always know which box has which address regardless
of which adapter I plug into it.

Let me know if I'm done :-)



On Sun, Dec 19, 2010 at 10:39 PM, James Cameron <quozl at> wrote:

> On Mon, Dec 20, 2010 at 02:27:58AM +0000, Kevin Gordon wrote:
> > Have to say I'm seeing the same as Mikus, the auto-assigned icons do
> > not appear in the frame.  The wireless ones, the 3G modems do appear,
> > and the USB when hooked to a DHCP providing ethernet router do.  But
> > on any of the XO 1s and 1.5s at 852 using the avahi workaround , they
> > do not .  Also I was able to 'get online' and share with chat when
> > wireless, but not when cross-over connected with the avahi workaround,
> > even though the machines do show in the network view map.
> Missing a default route or a 224.x.x.x broadcast route then.
> avahi-autoipd is not the only step required.
> --
> James Cameron
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Devel mailing list