ANNOUNCE: F11 for the XO-1 build 140py released

Mikus Grinbergs mikus at
Fri Apr 16 16:32:44 EDT 2010

> I have observed this problem a couple of times, although only after
> reflashing the OS. The machine would hang after displaying the frame of
> the boot animation with just one dot.

So far, if I've been running a machine, and it has hung -- and if it
doesn't want to reboot -- I will do the EC reset thing (unplug the AC,
take out the battery for a couple of minutes).

If an EC reset might be required also after reflashing the OS, then the
person doing the reflashing ought to be warned somehow (Release notes?
Wiki?).  My reason for mentioning the hang I saw was that I had not been
expecting a reflash to require an EC reset to make the os boot work.

> Please, take note of how you triggered it and
> how exactly you managed to solve it.

I triggered it by doing a 'copy-nand u:\os140py.img', then powering off,
pulling the USB stick, and powering on (while pressing the 'check' game
button).  [I already was using q2e42e from before doing the reflash.]

I never solved it - I repeated the power-up (I think twice) - and
finally the boot worked.  [Never did any explicit EC reset.]


More information about the Devel mailing list