[Sugar-devel] Problem installing and running hulahop on ubuntu 8.10

Tomeu Vizoso tomeu at sugarlabs.org
Fri Sep 4 13:31:11 EDT 2009

On Fri, Sep 4, 2009 at 19:15, vijit singh<vijitthetopcoder at gmail.com> wrote:
> Hi Tomeu,
> Thanx for replying.
>> You still get this error if you run this?
>> LD_LIBRARY_PATH=/usr/lib/xulrunner- python -c "import hulahop"
> Well, running this command was still giving errors, I mean it didn't started
> the python shell by itself, it simply ended, so in the next step I tried to
> run python explicitly, but still the error was there. However, when I tried
> the following command-
>  LD_LIBRARY_PATH=/usr/lib/xulrunner- python
> This invoked the python shell implicitly and now when I tried to import
> hulahop, it was getting imported.

Good, so the library is linked to correctly.

> However, still if I try to import
> hulahop.webview, it is giving errors. Here is the complete log-
> http://pastebin.be/20740

/var/lib/python-support/python2.5/xpcom/xpt.py:72: RuntimeWarning:
tp_compare didn't return -1 or -2 for exception

I think this is due to some python C modules being compiled with a
python version and others with a different version.

Can you check?



> It seems to me a bit strange, I mean when the hulahop module can be
> imported, then it should not give errors while importing individual files of
> hulahop, or may be I am missing something. Kindly give your suggestions.
> Regards,
> VIJIT aka sumit
>> Regards,
>> Tomeu

«Sugar Labs is anyone who participates in improving and using Sugar.
What Sugar Labs does is determined by the participants.» - David

More information about the Devel mailing list