first play with new XO 1.5 machines

James Cameron quozl at
Tue Oct 20 06:50:59 EDT 2009

G'day Tabitha,

Several of the experiences you mention are common to the recent Fedora
11 builds on both XO-1 and XO-1.5 machines.  Some are peculiar to the
XO-1.5 machines while development is continuing.

This trac query:
shows the experiences that are known to be peculiar to the XO-1.5.

You might also be interested in:

On Tue, Oct 20, 2009 at 07:04:15PM +1300, Tabitha Roder wrote:
> Testing 5 of the new XO 1.5 machines - our first experiences...
> hardware seems more responsive


> great touch pad - can feel edges and has tap click on touch pad so you
> dont have to push the button, we like it

Agreed, the edges are helpful.  I'd not noticed tap click.  It works.

> video card issues  with on screen animations - e.g. frame gives
> flickers on boot the display is a mass of colours - some kind of video
> driver fault

Boot animation corruption I also observed on os30, but not on os32.  You
didn't mention which build you were using.

Frame giving flickers is #9333.

> many keys only work intermittently on some of these XOs. particularly
> - frame key and the key next to it, search key, function key, hand
> keys, divide/multiply key.

I've not reproduced this.  I heard about a problem fixed in latest
firmware.  You didn't mention which firmware you were using.

> no mesh network showing in neighbourhood, could connect to our home
> wifi and browse internet, intermittently can see other XOs here (once
> we took out from network settings in my settings)


> the new record activity has no camera, only audio!
> camera issues...  video for linux working but doesnt like what it
> finds, a driver issue? doesnt know about the camera? tried looking for
> it, lspci, lshal, lsmod, no luck


> question - why is there a /media/boot in the frame next to the battery
> indicator and volume indicator,

Pass.  I hadn't noticed that.  It isn't there for me at the moment.  I
wonder why Sugar is showing it.

On mine, I see two battery indicators, #9353 relates.

> we took it apart and found there was a 4GB micro SD card for
> nonvolatile storage [...]


> and think 8GB SD RAM? 


> so upgradeable?

If you mean field upgrading of the micro SD card ... that would be a
deployment team nightmare, but yes, I guess so.  I'd hate to price it.

The RAM is not field upgradable.

The micro SD card is probably factory upgradable ... if prices or
deployment needs change prior to order, work could be done to meet
demand ... at some price.

On Tue, Oct 20, 2009 at 10:01:16PM +1300, Tabitha Roder wrote:
> tested install activity from browse - installed geoquiz-4 successfully
> from wiki.laptop and started game successfully


> tried installing foodforce2-beta.xo from - failed,
> gave file in journal but not activity
> can download foodforce2-1.xo from and does
> succesfully run

It would be interesting to find if this fails in the same way on Fedora
11 on XO-1.

James Cameron

More information about the Devel mailing list