[Server-devel] XS-0.6 -

Martin Langhoff martin.langhoff at gmail.com
Sat Oct 10 04:57:12 EDT 2009

On Sat, Oct 10, 2009 at 3:59 AM, Sameer Verma <sverma at sfsu.edu> wrote:
> On Wed, Oct 7, 2009 at 5:37 AM, Martin Langhoff
> <martin.langhoff at gmail.com> wrote:
>> 65d0816e002fe83f4e0130b6a92577377b9fd2e3  OLPC-School-Server-0.6-i386.iso
>> c872907f1f696ea7bb1bb6e95319fa27e62ce76c  OLPC-School-Server-0.6-i386.img.gz
> So, I have the SD card version running. Some points:
> 1) The new image takes 2GB only and not 4GB like the previous builds. Big plus.

If you run resize2fs (like the instructions say :-) ) right after
dd'ing it ot the SD it will expand the fs to take all the space in the

> 2) The first boot hangs on upgrading Moodle (see attachment).

On a slow SD I have here (class 6, fast when I do dd, but dead slow
random writes), it took some 20 minutes to init the Moodle DB.
Unfortunately, when it is init'ing the DB multiuser is not yet
enabled, so you can't get to other terminal to diagnose...

> 3) After hanging for over an hour, I power-cycled it and it booted up
> (just complained that accounts were already created).

And did it complete the Moodle install? What does
/var/log/moodle-instupg.log say?

> 4) /etc/sysconfig/olpc-scripts/domain_config <ourdomain.here> and a reboot.
> 5) We still have a problem with DNS forwarding. I had to manually add
> our DNS to /var/named-xs.conf it works ok.

So you need to add forwarders in your network...

> 6) Registration from XO was successful.
> 7) Accessing Moodle throws pgsql errors about workshop table...will
> attach in next e-mail.

We probably need a procedure to dump-and-recreate the Moodle DB
because now it is half-there and it probably won't init correctly any


 martin.langhoff at gmail.com
 martin at laptop.org -- School Server Architect
 - ask interesting questions
 - don't get distracted with shiny stuff  - working code first
 - http://wiki.laptop.org/go/User:Martinlanghoff

More information about the Devel mailing list