OS and Firmware testing for XO 1.5 B2: gnash

Peter Robinson pbrobinson at gmail.com
Wed Nov 18 09:53:01 EST 2009

On Wed, Nov 18, 2009 at 4:43 AM, John Gilmore <gnu at toad.com> wrote:
>> Gnash and youtube is a no go. No error now, just a black screen
> Within the last month, Youtube changed their default player to require
> Adobe Flash 10, including ActionScript 3.  Gnash does not yet implement
> AS3 properly -- that's why you got a black rectangle.
> The (shrinking) gnash team is working on this, but they won't have
> even an internal version that plays today's youtube before the end of
> November -- maybe much longer.
> There's a hack though:  rewrite the URL from:
>  http://www.youtube.com/watch?v=zeeie9l9taM
> to
>  http://www.youtube.com/v/zeeie9l9taM
> That uses the old player.  (The videos themselves are unchanged, it's
> just the stupid stuff around the edges, like the Play/Pause button,
> that's causing the trouble.)

I find both gnash and swfdec to be way too unstable and they are
massive cpu hogs so I use the totem YouTube plugin that works very


More information about the Devel mailing list