#9318 NORM 1.5-ATe: Via framebuffer failure on 1.5

Chris Ball cjb at laptop.org
Fri May 29 03:01:02 EDT 2009

Hi Harald,

   > [ I hope your bug tracker can take email responses, please tell
   > me if not ]

It can't, but I don't mind communicating by e-mail and updating the
tracker afterwards if you'd prefer.

   > mh, the problem must be related to that particular board, as I've
   > tested the code on both VX800 and VX855 (including a VX800 based
   > laptop with panel).  But thanks for letting me know.  viafb was
   > working on the device before?  What about the external VGA?

I've tried with a VX800 laptop with CRT+panel, and the 1.5 board with
CRT, and neither worked.  The fb init does not complete:

[   24.128168] vmap allocation for size 268439552 failed: use vmalloc=<size> to increase size.
[   24.136654] ioremap of fbmem failed
[   24.140759] viafb: probe of 0000:00:01.0 failed with error -5

It looks like it's trying to do DVI/panel output even though I only
had CRT connected, in this case (see the dmesg posted in the bug).
I'll look into it a little more, just wanted to give you a heads-up. 

   > After loading viafb from your xo-1.5 branch on the XO1.5 or the
   > VIA VX855 reference board, you should definitely get working
   > output on the VGA out.

'fraid not.

   > If even that doesn't work, something must have gone wrong while
   > rebasing my patches against the XO1.5 kernel tree.
   > [I'm offline till tuesday, will look into that after I return]

That's fine, thanks for looking at it.  It's not on the critical path,
so no rush.

- Chris.
Chris Ball   <cjb at laptop.org>

More information about the Devel mailing list