Problem creating .xo bundle

Gary C Martin gary at
Mon Jun 22 23:05:09 EDT 2009

Hi Art,

On 23 Jun 2009, at 03:40, Art Hunkins wrote:

> I've got an XO Activity ready to go, and working perfectly in my (XO)
> Activities folder. (It's called OurMusic.activity.)
> I just can't seem to make an .xo bundle of it.
> From my activity's folder (OurMusic.activity) I run:
> ./ dist_xo
> and get:
> : No such file or directory
> If I run:
> dist_xo
> or just
> I get:
> bash: command not found
> (and is right there in the folder, with correct permissions.)

Hmmm, so does have execute permissions (chmod +x

> Can someone give me guidance, please? (Happy to send along my  
> MANIFEST and files if relevent.)

My's just look like this:

#!/usr/bin/env python
from sugar.activity import bundlebuilder

Running ./ on its own should just give you its usage  

What environment are you developing under? Might give us some more  
clues :-)


P.S. You might want to join the sugar-devel mail-list ( 
), that's where most of the current folks working on Sugar/Activities  

More information about the Devel mailing list