[Testing] Notes from an impromptu 8.2.1 Release Mtg.

Hal Murray hmurray at megapathdsl.net
Fri Jan 30 19:25:41 EST 2009

> I still don't understand which version you are comparing to. Can't you
> just go to the control panel and check? 

That only gets me the currently installed version.  It takes a while to 
switch back to older versions.

Let me try again.

I'm using WPA, version 2 on a Linksys WRT54GL running their stock firmware.

In the past few weeks, I've had 3 versions of software on my XO.

I started with os759 from last Sept.  I think that is what was released.  
Most of the time, when I power up or Restart, it connects automatically.  I 
have to reboot a dozen times to get a case that fails.

I could time the reboot process by starting a ping to my XO, rebooting the 
XO, stopping the ping, and computing the lost packets.  There was no human 
activity in that process.

A while ago, I tried the software that was announced in the message that 
started this thread.   That's what I called 1352.  It came from:
That directory contains:
which is what I installed.
That web page says:
  OLPC Build staging-9 (devel_jffs2)
Looks like I should have called it build 9.  Sorry for the confusion.

I've never seen that connect automatically.  Most of the time, it worked when 
I poke the icon.

A few days ago, I tried build 25.  For me, it acts just the same as build 9 

> What is wpa.sh and why do you have to use it? You do know that the OS
> supports WPA out-of-the-box (although unreliable with some APs),
> right? 

It's a shell script that sets up the crypto stuff.  I think it was announced 
on devel ages ago.  My copy is dated Dec 2007.  It writes to:

It is option 4 from:

I use it because I have a big long password.  It's much easier to 
select/stuff than type in.

Is this the problem?  Does the new/current NetworkManager and/or Sugar need 
some info in some other location?  Somebody recognizes my AP since it has 
star on the icon and I don't need to enter a password when I poke the icon.

> Did you wait sufficiently long enough (perhaps as long as 5 minutes)
> for the XO to check mesh channels for school servers before consulting
> the history of infrastructure networks?

I wait until the icons stop blinking.  I haven't carefully reverse engineered 
the pattern and/or I'm not sure it's always the same, but it's something like 
scan the mesh channels, try my AP, then scan the mesh channels again.

That takes a while, but it's less than 5 minutes.  I have waited more than 5 
minutes a few times when I got distracted doing something else.  That didn't 

> Is the AP is marked as a favourite when it appears on the network
> view? It should have a star against the circular icon. 

Yes the icon for my AP has the little star.  (That's after running Wpa.sh  I 
don't remember looking before running Wpa.sh)  The star is how I find the 
icon to poke.  There are several other APs within range, usually 2 to 4.

These are my opinions, not necessarily my employer's.  I hate spam.

More information about the Devel mailing list