Problem running Sugar on openSUSE 11.1, MOSTLY fixed

James Simmons jim.simmons at
Thu Jan 29 10:56:02 EST 2009


I managed to figure out why my Activities weren't visible.  Only 
Favorite Activities show up in the ring, and none of mine were marked as 
Favorites.  I changed to the List View, marked them as Favorites, and 
all was well.  Almost.

Of all the Activities, I was only able to get Write, Terminal, and Chat 
to come up.  The others just did the pulsing icon thing for three 
minutes and vanished.

I tried to install my own Activities by copying them into the Journal 
from a thumb drive.  This didn't work.  The Copy icon in the Journal did 
not show the "Copy to Journal" option.  Also, I was unable to switch 
back to viewing the Journal after selecting the thumb drive option.  It 
just froze up.

This morning I tried again, and found that the Journal had emptied 
itself out.  It does that in the Xubuntu version of Sugar too.

I am attaching a file with error messages I get when running Sugar this 
morning.  I hope it will be of some use to you.

This morning I also discovered that Java wasn't working.  Run java with 
or without arguments and you get a bunch of error messages.  That 
convinced me its time to give up on openSUSE.

I have decided that the only way I'm going to get the robust Sugar 
environment I need is to run sugar-jhbuild on the latest Fedora.  That, 
I believe, will give me something close to what the Sugar developers are 
using.  I gave up on installing Fedora from the Live CD because it 
seemed to need more memory than I had available, but there is an install 
DVD also available so I'm going to try that.


James Simmons

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: sugerrs.txt
URL: <>

More information about the Devel mailing list