Notes from an impromptu 8.2.1 Release Mtg.

Hal Murray hmurray at
Mon Jan 26 02:26:45 EST 2009

> The main conclusion that we reached after we updated
> was that staging-9 [1] needs some testing! In particular, it's got
> long-awaited new wireless firmware and wifi kernel drivers which means
> that we need to know whether it still associates with your crazy
> encrypted access points. :) 

> [1]: (

That's Build 9, 1352 from 6-Jan.

What firmware should we be testing?

I'm using Q2E24.  There are several  later versions, but I didn't see 
anything that looks interesting in the web pages.  I don't remember any 
please-help-test-this messages but I could easily have missed one.  The 
latest version is Q2E28.  I'm reasonably sure that it didn't get much testing 
since I just fixed a typo on the wiki page in the URL to download the bits.  
Anyway, most of the testing below was done with Q2E24.  I've updated to Q2E28 
and a quick test didn't show any changes.

I have an early B3 board in a B2 chassis.  So any or all of this may be a 
wild goose chase.

It used to work reasonably well.  I think "It" was the last major release.  
>From the bits on my hard drive, that looks like 759.


Several quirks:

1) During setup, I normally ssh in via an USB Ethernet dongle so I can run  (I have a long password so select/stuff is much more convenient than 
typing it in.)

DHCP didn't work automagically like I expected it to.  I didn't investigate.  
ifconfig by hand worked.

2) For me, the new wireless is a step backwards.  My setup used to fail 
occasionally.  Now it connects occasionally.  After it connects it seems to 
work OK.

I'm using WPA version 2 on a Linksys WRT54GL  There are usually 2 to 4 other 
systems visible.  There are no other XOs nearby.  (At least none that I know 

I realize that "occasionally" isn't very precise.  I don't have hard numbers. 
 With the old system, roughly 9 out of 10 reboots automatically connected.  I 
had to go looking for one that failed.  (Normally, I don't reboot very often.)

With the new code, I've rebooted 10 times so far, but I haven't see any of 
them connect automatically.  I have seen the icon blinking while it tries.  
Usually it works when I manually poke connect.   I got a bit frustrated the 
second reboot when 3 pokes in a row didn't work.

At least once, the blinking icon stuff got confused.  Maybe because the 
underlying control code was confused.   I saw Mesh-11 blinking for a long 
time after I did a manual connect...

Is there anything I can do to collect useful debugging info?

3) I have now seen to the crazy-cursor symptoms that have been discussed 
here quite a bit.

It's possible that it's been there all along and I just haven't noticed it 
before or I didn't use the cursor pad enough to tickle it.  This time, I 
discovered the Implode activity and I have been playing with it.  It uses the 
cursor a lot.

I've seen one time where it was nasty enough to make the cursor totally 
unusable.  The cursor just kept jumping to the upper right corner.

I tried rebooting.  That didn't fix it.  A power cycle did.  That could be a 
wild goose chase.

Even when it isn't a total disaster, the cursor is still very hard to use.  
The problem seems to happen when I lift my finger off the pad so I can move 
it over and set it down to continue a long move.  Yes, I could be being 
sloppy and moving before I lift, but I've been working/playing with it enough 
that I don't think it's me, or if it is, other normal users will be totally 

Sometimes it jumps to the lower left corner.

Again, this is a B2 chasis with a B3 board.  If the cursor pad stuff has 
changed I apologize for the noise.

These are my opinions, not necessarily my employer's.  I hate spam.

More information about the Devel mailing list