Fedora Desktop on XO

Chris Ball cjb at laptop.org
Tue Jan 6 13:31:12 EST 2009

Hi Peter,

   > How did you go with this? Did you have any luck? I also realised
   > that if you drop gnome-user-share you'll drop all the httpd
   > requirements.

Yep, it worked!  I had RPM conflicts in GConf2 (against GConf2-dbus,
both ship the same .mo files) and evince (against sugar-evince, both
ship the same evince backend shared libraries).  Also, it turns out
that evince-dvi is responsible for bringing in texlive, via kpathsea.

Here's the command I'm using now:

-bash-3.2# yum -y install NetworkManager-gnome alacarte at-spi bug-buddy
 control-center eog file-roller gcalctool gdm gdm-user-switch-applet
 gedit gnome-applets gnome-audio gnome-backgrounds gnome-media
 gnome-panel gnome-power-manager gnome-screensaver gnome-session
 gnome-system-monitor gnome-terminal gnome-user-docs gnome-utils
 gok gthumb gucharmap gvfs-archive gvfs-fuse gvfs-gphoto2 gvfs-smb
 libcanberra-gtk2 metacity mousetweaks nautilus orca
 pulseaudio-esound-compat pulseaudio-module-gconf pulseaudio-module-x11
 scim-bridge-gtk xdg-user-dirs-gtk yelp zenity
Total size: 152 M

After that completes, you can put "exec gnome-session" in ~/.xsession
and restart X to land in a very normal looking F10 GNOME desktop.
(I haven't tried to do much with it yet.  Sound works, at least.)


- Chris.
Chris Ball   <cjb at laptop.org>

More information about the Devel mailing list