Secure or Unsecure?

John Watlington wad at
Mon Dec 7 18:29:02 EST 2009

    She probably has a machine with OS31 on it.   I doubt
olpc-update will work until she upgrades via OFW first.


On Dec 6, 2009, at 5:03 PM, Chris Ball wrote:

> Hi Caryl,
>> First, I don't know how to tell if the machine is secured or not.
> It's definitely unsecured.
>> As a "developer" machine it should be unsecured, but the firmware
>> version doesn't show up on the start-up banner. As a matter of
>> fact, there is no start-up banner, leading me to suspect the
>> machine is secured.
> We removed the banner by default, to make for a prettier boot.  To get
> it back, you can hold down the "check" game key while powering on.
>> I was able to find the firmware version (Q3A11) in the "About My
>> Computer" section. I need to get to Q3a18.
> Upgrading to the release candidate OS will install Q3A18, so you don't
> need to do that part of the upgrade yourself.
>> Secondly, I tried to do the update online on the XO, following
>> carefully the instructions on the q3a18 firmware section of the
>> wiki. No matter what variation of the commands I enter it comes
>> back with "No such file or directory" or "command not
>> found". Maybe I have a syntax error of some type, but I have
>> tried several variations with no luck.
>> Any suggetions?
> If you're talking about a command that starts with "flash", that's for
> the firmware, and not for the booted XO.
> To upgrade both firmware and software at the same time, open the
> terminal activity, go online, and type:
> sudo su -
> olpc-update f11_xo1.5-54
> <when finished successfully>
> reboot
> - Chris.
> -- 
> Chris Ball   <cjb at>
> One Laptop Per Child
> _______________________________________________
> Devel mailing list
> Devel at

More information about the Devel mailing list