[support-gang] Secure or Unsecure?

Richard A. Smith richard at laptop.org
Sun Dec 6 02:38:11 EST 2009

On 12/06/2009 01:15 AM, Caryl Bigenho wrote:

> First, I don't know how to tell if the machine is secured or not. As a
> "developer" machine it should be unsecured, but the firmware version
> doesn't show up on the start-up banner.
> As a matter of fact, there is no
> start-up banner, leading me to suspect the machine is secured. I was
> able to find the firmware version (Q3A11) in the "About My Computer"
> section. I need to get to Q3a18.

It is unsecure, but pretty-boot is enabled.  Press the Esc key during 
the startup sound and you will get a OFW 'ok' prompt.  Then you will 
also see the start-up banner.

> Secondly, I tried to do the update online on the XO, following carefully
> the instructions on the q3a18 firmware section of the wiki. No matter
> what variation of the commands I enter it comes back with "No such file
> or directory" or "command not found". Maybe I have a syntax error of
> some type, but I have tried several variations with no luck.

I suspect that you are entering these commands at the Linux prompt. 
Upgrading the firmware is done from the OpenFirmware 'ok' prompt.

See above for stopping at the OFW prompt and then you can upgrade your 
firmware with the wiki procedure.

Richard A. Smith  <richard at laptop.org>
One Laptop per Child

More information about the Devel mailing list