Battery recovery issues

Emiliano Pastorino epastorino at
Thu Apr 30 10:49:37 EDT 2009


I've just received a box with 60 faulty batteries inside, so I'll be playing
with them
for the next few years...

I did a "bat-recover" on one of them for about 18 hours and I noticed this:
When I run "watch-battery", it still says "No battery". I did a full-reset
of the XO
but nothing happened, it still says "No battery".
Then I loaded batman.fth and ran bat-charge and I got a nice output. All the
seemed to be OK when charging or discharging the battery.
I tried "batman-start; 6a bat-set-status; batman-stop" and I could see tha
6a in
the first block, but "watch-battery" still says "No battery".

What is the difference between batman's "bat-charge" and "watch-battery"?
Tell me if I'm wrong, but I think that "bat-charge" reads battery info
directly from it,
and "watch-battery" takes that info from the EC. So, the problem could be
the EC isn't synced with the battery. Am I right?

So long I could recover 2 batteries out of 4. I'll try more batteries, the
that seem to be ok now are the same model (GP NTA2490), and the other two
(the ones I couldn't recover even with bat-recover) are BYD LP183662AR-2S.

If you want me to do a particular test with any of these batteries, just ask
and I'll
share my results with you.

On Wed, Apr 29, 2009 at 2:25 PM, Richard A. Smith <richard at>wrote:

> Emiliano Pastorino wrote:
>>    Are you using the latest batman.fth?  I pulled a lot of batman
>>    functionality into the firmware and had to modify batman.fth to
>>    avoid the errors above.
>>  I'm using  0.3.6.
> Sorry.  I didn't have the latest up on the site.  Grab a fresh copy.
>  Is there any up-to-date document on how to proceed when recovering a
>> faulty battery  using recent firmware?
> No. But the difference is just running batman-start prior to bat-recover.
>  If you want to stop bat-recover then remove the battery. It will error and
> drop to an ok prompt.
>  Should I expect any output when running batman-start? I noticed that
>> battery interface is suspended,  but I don't see anything else
>> going on.
> Nope. And while batman is enabled don't expect the charge LED to do
> anything normal. It will flash in odd patterns.
>  Now I'm trying to recover a red led flashing battery. Suddenly, it went
>> from flashing red to nothing and I'm also getting "No battery" from
>> "watch-battery"
>> and 0 1 2 0 1 2..... from "see-bstat".
>> When the led was flashing red, I could get an error code of "2" from
>> "ec-abnormal@ .". Now I'm getting "0". I'd like to know what that 2
>> meant. Where
>> can I get the explanation of those error codes?
> The error list on the wiki is a bit out of date.  I'll work on updating a
> list on the battery diagnostics page.  A 2 mean that the status register
> setting in the battery gas gauge was not what the EC expected it to be.
>  This happens every so often and is usually transient.  If it was actually
> written into the EEPROM and you get that every time then please do a
> bat-dump-banks and look at the value in the 2nd line of bank0, Col 1. It
> should be 0x6a if is not then you can use bat-set-status to fix it.
> ok batman-start
> ok 6a bat-set-status
> ok batman-stop
>  I'll be testing more faulty batteries, so I'll be bothering here
>> periodically :)
> No problem.  Please help me keep the battery diagnostic page up to date
> with things that you find.
> On that note.  I need to get with you sometime and get some charge logs.
> I'm want to know how the capacity of the batteries you have had out in the
> field are holding up.
> --
> Richard Smith  <richard at>
> One Laptop Per Child

Ing. Emiliano Pastorino
LATU - Plan Ceibal
Av. Italia 6201 CP: 11500, Montevideo, Uruguay
Tel: (598 2) 601 5773 int.: 210
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Devel mailing list