XO Camera

Peter Robinson pbrobinson at gmail.com
Fri Apr 24 02:52:54 EDT 2009

Hi Jon,

> [Sorry for the slow response, I am losing the battle with my inbox in a
> spectacular way...]
>>    > I've been playing with rawhide on the XO this morning now that
>>    > I've finally got it booting of the SD easily and regularly. It
>>    > seems the camera doesn't work either in the record app or in
>>    > cheese. Looking at the dmesg output it looks like the sensor
>>    > isn't supported in the rawhide kernel. Is there a kernel patch
>>    > that needs to go upstream for support for this as well?
>>    > dmesg output: ov7670 0-0042: chip found @ 0x84 (cafe_ccic)
>>    > cafe1000-ccic 0000:00:0c.2: Unsupported sensor type
>>    > 0x1<4>cafe1000-ccic: probe of 0000:00:0c.2 failed with error -22
>> This support should be already upstream.  I'd try building the module
>> reverted to Linus cd257a6f4dd, in case one of the recent commits to
>> ov7670/cafe_ccic broke detection.  Jon, any ideas what this might be?
> Which kernel are you running?

The kernel is the rawhide variant from about a week ago.

> Hans Verkuil (CCed) made a lot of changes for 2.6.30; I meant to try
> them out, but, in the time I had available, I never did succeed in
> getting a contemporary system running on my XO.  So there is a lot of
> untested code in that driver in 2.6.30; given the nature of the
> changes, a detection failure seems like a likely problem.

OK, not sure whether the rawhide kernel has pulled any .30 changes in
but its always possible.

> The fact that it's seeing something at 0x84 is a little suspicious.
> Hans has an XO now; I'm not sure how far he's gotten in trying things
> out.

Cool. Thanks for the update.


More information about the Devel mailing list