Major power concern

Robert Howard rihoward at rawbw.com
Thu Oct 2 23:41:15 EDT 2008


Pia,

 From my reading of your description you ran the 765 and 711 test on  
2 different machines and did not swap the battery between machines.   
Is this correct?
If so there is a flaw in the methodology.  You should ideally run all  
tests on the same machine with the same battery or at least use the  
same battery in both machines for the test.

To determine if it is a battery problem follow the instructions for  
using opc-pwr-log. (This should be pre-installed on 757).
The instructions are at:

http://wiki.laptop.org/go/XO_LiFePO4_Recovery_Procedure

/Robert H.

On Oct 2, 2008, at 3:53 PM, Pia Waugh wrote:

> Hi all,
>
> I've just noticed that release candidate 765 when fully charged  
> tells me I
> have 2 1/2 hours of usage. This is a major concern, and something  
> we really
> need to fix for this release. As I tested it, it appeared to get  
> about a
> minute or two to each percentage of battery. Below are some initial  
> results
> as I know people want them sooner rather than later :)
>
> I was asked in #olpc to see if ohmd is running. It is. Anything  
> else I can
> check for? I found that by default the "power savings" option was  
> turned
> off. I turned it on for one of the test laptops below.
>
> All laptops were simply turned on and the mouse hovered over the  
> battery
> symbol for status, no apps were run nor other activity run.
>
> The % is the indicated remaining battery time.
>
> Test 1 - default 765 image
>
>     765 started at (98%) fully charged
>     64% 1.48hrs remaining @ 65 mins running time
>     50% 1.24hrs remaining @ 98 mins running time
>     45% 1.16hrs remaining @ 108 mins running time
>
>     Estiamted time = ~2 1/2 - 3hrs
>
> Test 2 - default 765 image but with power savings on
>
>     765 started at (93%) mostly charged with power savings turned on
>         and rebooted
>     93% @ 0 mins running time
>     92% @ 2.35 10 mins running time
>     90% @ 2.32 35 mins running time
>     90% @ 2.32 41 mins running time
>     90% @ 2.32 50 mins running time
>
>     Estimated full time = ~10hrs+
>
> Test 3 - default 711 image
>
>     711 build started at (97%) fully charged (no percentage available)
>     94% @ 10 mins running time
>     89% @ 23 mins running time
>     84% @ 35 mins running time
>     73% @ 68 mins running time
>
>     Estimated time = 4-5 hrs
>
> Please note these are initial results and I won't know for sure until
> another few hours for the first round, and a few repeats, but at  
> least this
> gets other able to start testing :)
>
> This issue could be a major problem for this new release and if  
> unfixed
> would seriously undermine the awesome efforts of all involved in  
> the great
> changes for 8.2.0.
>
> Just for reference I've seen trials for primary schools with other  
> devices
> and one of the main benefits of the XO over them was better power,  
> so we
> need to maintain that :) If you are interested the other main  
> reasons were
> screen size, the ease of prepacking a full suite of apps/content, the
> relative cost of the wireless infrastructure needed, and the community
> around OLPC.
>
> Cheers,
> Pia
>
> -- 
> Linux Australia                                         http:// 
> linux.org.au/
> Open Source Industry Australia                           http:// 
> osia.net.au/
> Software Freedom Day                          http:// 
> softwarefreedomday.org/
>
>    "He who loves the world as his body may be entrusted with the  
> empire."
>                                  - Lao-tzu
> _______________________________________________
> Devel mailing list
> Devel at lists.laptop.org
> http://lists.laptop.org/listinfo/devel



More information about the Devel mailing list