OFW trackpad test woes

rihoward1 at gmail.com rihoward1 at gmail.com
Sun Oct 5 12:18:24 EDT 2008


Just been testing q2e19a and the self test mode is still buggy. I am  
testing with a G1G1 laptop with Alps trackpad.
Seen several different things happen.

I ran the complete self test a couple of times by cold booting with  
the left rocker  held down.
1.) One time when it went into the mouse test phase as soon as I  
touched the right hand section of the touchpad it left the mouse test  
and went to the next test.

2.) When I ran test mouse from the ofw prompt the screen was left  
black until I hit enter a few times.

3.) Another problem is when you  run 'test mouse' from the ofw prompt  
the screen the following may occur:
"Pressure:    10
Touchpad protocol botched

mouse selftest failed.  Return code = -1

Touchpad test. Both buttons clears screen.  Type a key to exit."

I can repeat number 3 just by running finger around trackpad while  
varying pressure.

On Oct 5, 2008, at 2:48 AM, Mitch Bradley wrote:

> http://dev.laptop.org/~wmb/q2e19a.rom is a test build that purports  
> to fix http://dev.laptop.org/ticket/8451#comment:7 (This Time For  
> Sure !)
> If anybody is just itching to test a bleeding edge OFW, this is  
> your chance.  (Okay, so it's not really all that bleeding.  It's  
> not too different from Q2E18 which is going in the G1G1V2 build.)

More information about the Devel mailing list