Problem with Stream Tubes over the Mesh

Kristofer Plunkett kp86 at
Fri May 30 21:04:58 EDT 2008

Thanks for your response, Guillaume.

First, to clarify:  I have not tried sharing the activity over a Jabber
server, so I've only seen it work (and not work) over Gabble.

Next, I've been trying for almost a good week now to reproduce this bug.  It
seems that as soon as I turned on debugging, everything works just fine.
Sharing the activity over the local mesh has worked every time I've tried
since last week.  I really dislike Heisenbugs...

If this issue reappears, I will make sure to open a ticket and post all
appropriate logs.  Thanks for all the great info and links.

If anyone would like to try out the activity and see if sharing over the
mesh works for them, my team and I would very much appreciate it.  We would
invite you to visit our site ( and download the Beta.
Unfortunately, we don't have any user documentation available yet, but
between our site and wiki, I'm confident all you smart hackers out there can
figure everything out.  Just remember to use the .cpxo files on the
downloads page.


On Mon, May 26, 2008 at 1:38 AM, Guillaume Desmottes <
guillaume.desmottes at> wrote:

> Le dimanche 25 mai 2008 à 21:05 -0700, Kristofer Plunkett a écrit :
> > Hello,
> >
> > I'm developing an activity in Sugar that uses stream tubes to transfer
> > data (slide shows, in particular).  The code I'm running to accomplish
> > this is almost an exact mirror of the Read activity, which seems to be
> > the defacto example of how to use stream tubes.  When sharing the
> > activity and using the tubes over a wireless AP, everything works just
> > fine.  However, when doing the same over a mesh network, things don't
> > work.  I've confirmed that the HTTP server is running on the correct
> > port and works correctly on the XO that is sharing the data, and, once
> > the joiners have acquired the stream tube, I confirmed that the
> > correct port is opened on localhost on those machines.  When the
> > joiners attempt to download the data from the tube (forwarded socket),
> > they are able to connect but then the connection is reset as soon as
> > the request is sent.
> So it works when you are connected to a jabber server but not when using
> simple mesh, right?
> Could you please open a ticket [1] on the telepathy-salut component?
> I'll need telepathy-salut.log to help you with this issue. See [2] for
> details.
> thanks,
>        G.
> [1]
> [2]
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Devel mailing list