No kernel messages displayed on 2.6.26-rc2

Denver Gingerich denver at
Fri May 23 01:12:58 EDT 2008

I built a kernel from the latest git source and tried to boot it on my
C2 XO-1, but I could not see any of the kernel messages while it
booted (using "Check-Key Boot") and instead saw only a white screen.
Furthermore, the kernel likely did not finish loading because the next
clean boot did not force a fsck as it usually would when the machine
was improperly shutdown (I am running Ubuntu on an SD card).  When
booting 2.6.26-rc2, I left it at the white screen for about 2 minutes
before doing a hard shutdown (holding the power button).

I tried booting 2.6.26-rc2 with and without the check key held at boot
time, according to
 In both cases, the screen turned white after the boot loader
countdown.  Also in both cases, the camera LED flashed (one quick
on/off cycle) after a couple seconds of booting, followed by the mic
LED turning on and staying on.  This is similar to what happens when
booting 2.6.22-20071121.7 except that the mic LED flashes once instead
of staying on and I can see the kernel messages.  In the case where I
did not hold the check key on the 2.6.26-rc2 boot, it took a couple
more seconds for the screen to turn white.

I'd like to know how to go about diagnosing this problem further.  I
don't have a serial adapter, although I would consider getting one and
connecting it if needed.  What I'm really interested in is some
details on how the display is initialized so that I can see why the
kernel messages are displayed in the 2.6.22 and 2.6.25 kernels I've
tried but not in the 2.6.26-rc2 kernel.  What causes this
initialization to happen?  I have xdm set to load on startup, but if I
don't hold the check key while booting 2.6.22, the screen never
switches from the OFW start screen to the xdm screen, suggesting that
the display was not initialized properly.  Why is that?  Is there
something extra needed that isn't invoked by an unmodified X?

The reason I ask is that it seems like I could get something to show
up on the screen (even if the kernel and other boot messages didn't
appear) if only something like X would re-initialize the screen.  But
this does not seem to be the case, not for 2.6.22 and definitely not
for 2.6.26-rc2.

For the record, this is the olpc.fth file that I'm using to boot from OFW:
\ Boot script
" ro root=/dev/mmcblk0p1 rootdelay=1 console=ttyS0,115200 console=tty0
fbcon=font:SUN12x22" to boot-file
boot sd:\boot\vmlinuz

If you would like to see the kernel binary I'm using, let me know and
I'll send it to you.  Let me know if you have any questions about my
setup or suggestions for what I should try next.


More information about the Devel mailing list