Sugar jhbuild bug

Tomeu Vizoso tomeu at tomeuvizoso.net
Wed Mar 12 11:22:40 EDT 2008


On Wed, Mar 12, 2008 at 2:56 PM, James Simmons
<jim.simmons at walgreens.com> wrote:
> I'm trying to set up sugar-jhbuild on my OpenSuse 10.2 computer.  When I
>  was satisfying all the dependencies reported by the "build" option I
>  noticed one that seemed very odd.  It wanted automake 1.7.  Open Suse
>  installs automake 1.9, and I would have thought anything 1.7 or greater
>  would work.  I satisfied all the other dependencies first, hoping this
>  would go away, but it stayed to the end and "build" would not budge
>  until I fixed it.  I downloaded automake 1.7.9 source and installed it
>  in /usr/local/bin, and that seemed to be enough to get sugar-jhbuild
>  working again.  Then I got this message:
>
>  configure.ac:8: require Automake 1.9, but have 1.7.9
>  autoreconf: automake failed with exit status: 1
>
>  That's a Catch-22 if I ever saw one.  I let the build keep running,
>  skipping over the modules that won't compile.  It's pretty obvious that
>  I won't have anything workable afterwards, though.  I would guess there
>  are a lot of sugar-jhbuild users on this list, and I'd appreciate any
>  suggestions.  I can easily uninstall automake 1.7.9, the question is
>  what to do after that.

Hi, just in case it helps somehow in OpenSuse, here in ubuntu gutsy I
installed automake 1.7.9 and 1.9 from the standard repos and things
work fine.

Tomeu


More information about the Devel mailing list