joyride keyboard problems & GL/glx

Ton van Overbeek tvoverbeek at
Fri Jul 25 10:22:50 EDT 2008

On Thu, Jul 24, 2008 at 9:44 PM, Daniel Drake <dsd at> wrote:
> Just a quick FYI: the keyboard bugs in recent joyrides (various buttons
> not working or misbehaving) is fixed by the X server update in joyride 2207.
> The problem was that a Fedora 9 update included an updated evdev driver,
> which had been compiled against a newer X server (we have forked
> xserver, so we don't automatically get updates there). I have resynced
> our xserver with Fedora's so we support the new ABI which evdev uses.
> Resyncing the X server was not quite as simple as you might expect.
> Previously, X was compiled along with the mesa sources to offer
> software-based GL. The software GL is very slow but word on the street
> is that some activities use it anyway.
> In the newer X server, the software GL implementation (dri_swrast) has
> been moved to mesa, which we don't include in our builds. The newer X
> server also includes a bug which caused it to crash when no swrast was
> present, I wrote a patch included in our build which I will be
> committing to freedesktop git upstream shortly...
> Anyway, at the moment, we have no swrast in our build, which means no GL
> support at all. Does anyone care?
> I am going to work with Fedora to get the swrast module separated from
> the overweight mesa-dri-drivers - this could return in future if we need it.
> Sorry for any inconvenience, this was the most straightforward way of
> getting a working X and a working keyboard again.
> Daniel

Just FYI. Tried to boot both joyride-2207 and joyride-2210 (the
devel-ext3 variant) on
qemu (on win XP/SP2) but both fail with the same error:
(EE) AIGLX error: dlopen of /usr/lib/sri/ failed
(/usr/lib/dri/ cannot open shared object file: No such
file or directory)

Fatal server error:
GLX: could not load software rendered

giving up.
Is this something specific for emulation ???

Ton van Overbeek

More information about the Devel mailing list