[sugar] Abiword 2.6.4 on Ubuntu (was Re: Write needs your help)

Ryan Pavlik abiryan at ryand.net
Thu Jul 17 18:20:42 EDT 2008


Edward Cherlin wrote:
> On Thu, Jul 17, 2008 at 1:54 PM, Tomeu Vizoso <tomeu at tomeuvizoso.net> wrote:
>   
>> Sorry, what I meant is that, ideally, we would be testing Write in
>> joyride with the 2.6.4 version. As we don't have that version in
>> joyride yet, I think the closest we can do is testing Abiword 2.6.4.
>>     
>
>   
>> Thanks,
>>
>> Tomeu
>>     
>
> It appears that the 2.6.4 sources aren't configured to build correctly
> on Ubuntu using configure and GNU make.
>
> ./configure reports
>
> configure: error: No package 'glib-2.0' found
>
> (The correct name on Ubuntu is libglib2.0-0)
>
> Then make says:
>
> Building AbiSuite with [ABI_ROOT=/home/mokurai/tmp/abiword/abiword-2.6.4]
> make ABI_ROOT=/home/mokurai/tmp/abiword/abiword-2.6.4 -C src
> make[1]: Entering directory `/home/mokurai/tmp/abiword/abiword-2.6.4/src'
>
>     I can't seem to figure out which platform you are using.
>
>     You should probably try using the autoconfiscated build system (rather
>     than this, the deprecated and unsupported diving make system) by running
>     configure (creating it with autogen.sh if need be) and using GNU Make.
>     Using configure is a requirement for all known platforms that
> aren't some form
>     of Windows, QNX Neutrino, or MacOS X.
>
> exit 1
> make[1]: *** [fake-target] Error 1
> make[1]: Leaving directory `/home/mokurai/tmp/abiword/abiword-2.6.4/src'
> make: *** [compile] Error 2
>
>
> Does anybody have a workaround? Would someone like to fix configure to
> work on Ubuntu? Do the makefiles need any change?
>
> So far I have the old version of Write that Ubuntu offers accepting
> and displaying Cyrillic and Greek correctly. I'll wait until I have
> something up-to-date to test before proceeding to the other 30+
> possibilities.
>
> Kim, should we create a process for globalization QA? We need testing
> for Amharic, Arabic, Khmer,
>
>   
You might want to look at the Ubuntu instructions on abisource.com to
add the "abiword-stable" PPA, which will give you packages of a recent
version (2.6.3 right now, I'm very close to putting up 2.6.4) and
furthermore it will let you get source packages (just add the deb-src
line to match) and "apt-get build-dep abiword"

Ryan

-- 
Ryan Pavlik
www.cleardefinition.com

#282  +  (442) -  [X]
A programmer started to cuss
Because getting to sleep was a fuss
As he lay there in bed
Looping 'round in his head
was: while(!asleep()) sheep++;



More information about the Devel mailing list