Unable to update my machine

Kim Quirk kim at laptop.org
Thu Aug 30 22:52:29 EDT 2007


It sounds like you have tried a lot of things, but you don't mention
downloading the latest copy of olpc-auto.zip, which is required these days.
This file has been updated quite a few times recently so the latest version
should be downloaded whenever you get a new build.

The Autoreinstallation page of the wiki is very detailed and also has been
updated quite a bit in the last few weeks to help people with installation.
If you haven't read through that page carefully in the last few days, please
start there and follow the instructions carefully. Over time this will get
easier and it won't change with every build... but since we added the
ability to backup and restore and the activation key, it has taken a number
of weeks to get this process stabilized.

If you HAVE carefully read through the autoreinstallation page and you are
still having a problem, then we may need to see your machine or maybe we can
go through the installation together on irc.

Keep me posted on your progress,
Kim Quirk

On 8/30/07, Philip Macpherson <philipmac1 at gmail.com> wrote:
> To Devel list
> I've got a b4 which I've upgraded once when I first got it and am unable
> to update since.  I'm using the same usb flash key as I used the first
> time.  I first tried it unsuccessfully with all the files the same except
> for updated firmware .  Since then I've tried multiple times with the same
> files and later with the newer firmware and newer build.  I've also tried re
> downloading the files along with reformatting the stick (as both FAT 16 and
> 32)to see if it helps.
> When I insert the stick and turn on the machine with the x key pressed it
> recognises the key is there but doesn't seem to see the script.  As it
> doesn't  mention that it's either upgrading the machine or if it's firmware
> is current.
> The only difference I see after this happening is the usb stick now has a
> folder on it called .olpc.store
> The usb stick has only one partition and as far as I know sector sizes of
> 512 (fdisk didn't tell me otherwise when I loaded the stick with it).  I
> have build 542, q2c22 currently installed and have tried installing q2c25,
> both on it's own (with 542 still being in the boot folder) and with the
> newer build 558.  But have failed as described above.
> Thanks for your help,
> Philip
> P.S Sorry for the grammar, it's really late
> _______________________________________________
> Devel mailing list
> Devel at lists.laptop.org
> http://lists.laptop.org/listinfo/devel
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.laptop.org/pipermail/devel/attachments/20070830/12e36a9d/attachment.html>

More information about the Devel mailing list