[olpc-help] xo laptop boot-up problem

Steve Holton sph0lt0n at gmail.com
Thu Jun 5 10:43:27 EDT 2008

On Thu, Jun 5, 2008 at 10:25 AM, Christian Bayens
<christianbayens at gmail.com> wrote:
> Hi,
> i recently bought an xo "one child per laptop" laptop and it's having
> trouble booting up. I will press the power button then the logo will come up
> and it'll play the little song. After that, it will go to the symbol with
> the dots. This is where the problem is. it will get to the first dot but it
> won't keep going around. I read that the first dot is when the laptop
> connects with it's firmware and i'm guessing that that is the problem. so if
> you can provide any help, that would be great.

Hi Christian-

If you've got the circle, you're part the firmware. This sounds more
like the internal flash has filled up, but that's just a guess at this

Try rebooting the XO while holding down the 'checkmark' button on the
gamepad. This will display additional diagnostics. That may give you
some ideas, or you can post back here and we'll see if there are ideas
from the peanut gallery.

If you think the problem might be related to a failed upgrade, you
might try holding the "circle" button on the gamepad. if there is an
older restore image still available, this will allow you to boot into

Additional details here:
-  http://wiki.laptop.org/go/Startup_Diagnosis
-  http://wiki.laptop.org/go/Cheat_codes

Steve Holton
sph0lt0n at gmail.com

More information about the community-support mailing list