[olpc-help] G1G1 will not work

Denver Gingerich denver at ossguy.com
Wed Feb 27 23:08:26 EST 2008

On Wed, Feb 27, 2008 at 10:26 PM, Philip Simmons
<philip.simmons at gmail.com> wrote:
> Hello
>  I purchased for my child for Christmas and the machine now will not
>  work.  Is there some sort of warranty?
>  The particular issue with seems to be a known issue, at least as far
>  as I have been able to tell from the research I have done.  I can get
>  the machine to start and get to the home page but when I select any of
>  the activities it will show "starting..." and it will sit like this
>  until we power it off and try again.
>  Now, I tried to update the software...it appears this has build 650
>  and I downloaded the most recent stable build (I think 656) but I am
>  unable to perform the update.  I followed the instructions on the
>  website that have me enter terminal...but when I attempt to enter
>  terminal it simply says starting...  I also tried control/alt/fn/2 and
>  I get a login and have tried (from the instructions on the web) su -
>  and sudo -i but either route I get a request for a password.  I never
>  set a password for the machine and got from the company so have no
>  idea what the password is...is there a work around for this?  Can I
>  somehow reformat and just put the new software on the machine?

Yes, you can.  Follow the instructions at:


This will delete anything you've created on your XO since getting it,
but if you haven't been able to do anything on it, that shouldn't be a

Reply back to the list if you have any issues with the upgrade.


More information about the community-support mailing list