[olpc-help] Connecting to internet

BuckXO community-support at lists.laptop.org
Thu Dec 27 20:18:42 EST 2007

I finally got my QWEST Actiontec wireless DSL modem working with the XO. Here are symptoms and things I tried which may be helpful to those with similar problems. My modem was working fine with three non-XO PC's.

Initially my Actiontec would show up intermittently, or not at all, in Neighborhood view. Attempts to connect, when it would show up, would fail. (Flash and then stop without connection)

I changed wireless channels (Lower numbers) and could then get the XO request for WEP key.  I had a 64-bit WEP programmed in the modem and the XO doesn't have an option for that. I reconfigured the modem for 128 bit WEP (HEX)

The XO would then connect, but throughput to the internet was spotty, at best. Most site requests would time-out. Changes to channels did not help. (The XO worked great with an unsecured site in my area, so I knew what a good connection and throughput should do.)

I upgraded the modem's firmware to the most recent release and now it works great. Either the upgrade made the difference or the old firmware was corrupted somehow. I had upgraded from version QW03-3.60... to version QW05.5-3.60....

I am now on Channel 3, 128 bit WEP key, open authentication. All is well so far.

The firmware upgrade is very non-threatening: 
Here is the site to get to actiontec firmware downloads:

Good Luck


More information about the community-support mailing list