#12934 NORM Not Tri: Android 4.3.1/Fedora dual boot no longer boots

Zarro Boogs per Child bugtracker at laptop.org
Sat Nov 25 16:47:33 EST 2017

#12934: Android 4.3.1/Fedora dual boot no longer boots
     Reporter:  fatalbert  |                 Owner:  suyouxin
         Type:  defect     |                Status:  new
     Priority:  normal     |             Milestone:  Not Triaged
    Component:  android    |               Version:  not specified
     Keywords:             |            Blocked By:
     Blocking:             |  Deployments affected:
Action Needed:  never set  |              Verified:  0
 This was working previously:

   ok fs-update u:\32014a4.zd

 Hold down (O) button while booting for android, or do nothing to get
 Fedora. I later flashed the pure Fedora image:

   ok fs-update u:\32019o4.zd

 and also did some firmware upgrades.

   ok flash u:\q7c06.rom  (a while back)
   ok flash u:\q7c07.rom  (today)

 Still no issues.  Then I tried going back to Android.  Tried both of

   ok fs-update u:\32014a4.zd (as before)
   ok fs-update u:\lollipop_20150203.zd (from http://dev.laptop.org/~ben/)

 They both fail to boot.  The jellybean image (32014a4.zd) is a dual boot
 config and both android and fedora fail to boot on that image.  Here's the
 boot-time output of the dual boot image (32014a4.zd):

 Boot device: /sd/sdhci at d4281000/disk:\boot\olpc.fth Arguments:
 Trying last:\boot\ecfw4.zip
 Trying last:\boot\ecfw.zip
 Trying last:\boot\bootfw4.zip
   FW found - current FW is up-to-date
 Trying last:\boot\runos4.zip
   OS found - Trying last:\boot\runrd4.zip
   RD found -

 and from there it's hung.  I can always flash to a pure Fedora image and
 that continues to work.  But flashing either Android image now results in
 an unbootable machine.  The only theory I have is that the recent firmware
 has somehow broken Android.  I have double checked the md5sums, files are

 I have tried several times with different source media:
   * vfat, formatted with: ok d# 2048 fat32-partition ext
   * ext2, formatted in a debian system

 Both tried using the SD slot:
     ok fs-update ext:\...
 and also with the SD card in a card reader:
     ok fs-update u:\...

 I have also tried using the SD slot as a target:
   ok devalias fsdisk ext:0
   ok fs-update u:\32014a4.zd

 I have also tried moving the SD card from the slot to a card reader to
 boot from USB.

 The flashing always reports success, bootup always fails for Android

 This is an xo-4 touch, unsecured.

Ticket URL: <http://dev.laptop.org/ticket/12934>
One Laptop per Child <http://one.laptop.org/>
One Laptop per Child bug tracking system

More information about the Bugs mailing list