#11363 NORM 1.75-so: XO-1.75 mouse sometimes unusable on boot

Zarro Boogs per Child bugtracker at laptop.org
Thu Dec 15 09:23:16 EST 2011

#11363: XO-1.75 mouse sometimes unusable on boot
           Reporter:  dsd       |       Owner:  saadia       
               Type:  defect    |      Status:  assigned     
           Priority:  normal    |   Milestone:  1.75-software
          Component:  kernel    |     Version:  not specified
         Resolution:            |    Keywords:               
        Next_action:  diagnose  |    Verified:  0            
Deployment_affected:            |   Blockedby:               
           Blocking:            |  

Comment(by pgf):

 Replying to [comment:11 avatar]:
 > By booting a kernel without mmp-camera module(CONFIG_VIDEO_MMP_CAMERA),
 I no longer get "''psmouse.c: Failed to enable mouse on
 olpc_touchpad/serio''" message anymore.

 thank you for this report.   i have a pending firmware change which will
 definitely help with this issue, but i'm at a loss as to how the camera
 might affect it.  i'll investigate that.

 fyi, a much faster way to reproduce the problem, without rebooting, is:

 modprobe -r psmouse; modprobe psmouse

 this is known to fail completely after the laptop has suspended and
 resumed at least once, so it's a more interesting test before the first

Ticket URL: <http://dev.laptop.org/ticket/11363#comment:12>
One Laptop Per Child <http://laptop.org/>
OLPC bug tracking system

More information about the Bugs mailing list