#5854 LOW Future : provide dummy eth2 device for non-NetworkManager connection

Zarro Boogs per Child bugtracker at laptop.org
Fri Nov 21 20:11:42 EST 2008

#5854: provide dummy eth2 device for non-NetworkManager connection
           Reporter:  mikus            |       Owner:  dcbw          
               Type:  enhancement      |      Status:  closed        
           Priority:  low              |   Milestone:  Future Release
          Component:  network manager  |     Version:                
         Resolution:  wontfix          |    Keywords:  wired ethernet
        Next_action:  never set        |    Verified:  0             
Deployment_affected:                   |   Blockedby:                
           Blocking:                   |  
Changes (by mikus):

  * status:  new => closed
  * next_action:  => never set
  * resolution:  => wontfix


 I'm closing this because it has been sitting around too long.  The basic
 problem was that when I set up a manual connection over my wired ethernet,
 the Network Manager came along later and took down the connection I had
 made.  Testing in Nov 2008 with NM 0.7, usually the NM leaves my manual
 connection alone after I have set it up -- but sometimes it doesn't.  If I
 can find a reproducible scenario where NM 0.7 interferes consistently,
 I'll write up its interference as a new problem ticket.

 In the meantime (assuming that I do *not* want to also use the mesh in
 addition to my ethernet connection), I am explicitly stopping Network
 Manager from interfering by:  'service NetworkManager stop', then
 'ifconfig eth0 up netmask' plus 'route add
 default gw'.  Four times out of five that sets up my wired
 ethernet correctly (the fifth time I do 'ifconfig eth0 down' and repeat
 the process).


 What I originally wanted to do in ticket #5854 was to be able to set up a
 wired connection that was *not* subsequently interfered with by Network
 Manager.  At the time, if I "re-used" an interface that *was* controlled
 by the Network Manager, it subsequently did interfere.  So I asked for a
 "dummy" device that would be outside of the control of Network Manager.
 Today, I can stop Network Manager, and then reuse the existing devices.
 But ultimately, there needs to be a way to tell Network Manager "hands
 off" an explicitly desired connection (this need will sooner or later
 generate yet another enhancement request).

Ticket URL: <http://dev.laptop.org/ticket/5854#comment:5>
One Laptop Per Child <http://laptop.org/>
OLPC bug tracking system

More information about the Bugs mailing list